• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Zdravím hosta! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi (RaspberryPi) nevidí NAS
#1
Zdravím

Klasická historka: Fungovalo to rok, nic jsem nedělal a zničeho nic to přestalo fungovat...

Bohužel, je to tak. Mám síť:
  1. MacMini, ke kterému jsou připojeny 3x externí disky a který mi slouží jako domácí NAS (a také je na něm KODI a je připojen k jedné TV
  2. Domácí síť a bránu mi zajišťuje Turris
  3. Dále mám 2x RaspberryPi s KODI u dvou TV

Fungovalo to takto rok a pak jednoho dne, z ničeho nic, ani jedno RPi se nepřipojilo k disku, který je na NASu (tedy na MacMini). Rychle jsem to vyřešil instalací Plexu na MM a klientů Plexu na RPi, ale chci tam dát KODI. Tedy jsem stáhl dnes instalaci ze stránek KODI (OSMC) a nainstaloval na kartu. Systém se rozjede, ale stále nemám šanci se připojit na MM a jeho disky.

V Nastavení OSMC vidím, že má IP přidělenou z DHCP. Změnil jsem i název sítě na tu, kterou mám nastavenou (byl tam i WINS server a nastavil jsem IP od MacMini, ale netuším, zda je to OK). Když dám vyhledávat v síti, tak zadávám přímou cestu \\IPADRESA\NAZEVSLOZKY, ale vždy se mi jen vypíše "Connection Timed Out".

Googlil jsem, ale jsem starší ročník a neumím anglicky a z překladače jsem nepochopil, kde je problém  jak vyřešit. Nevím, jestli je problém v KODI, RPI, Turrisu a nebo OS X a MM. Když jsem to řešil dříve, tak po mě chtěl někdo logy, ale ani nevím, kde takový log najdu.

Neporadí někdo?
 
Citovat
#2
Něco podobného se řešilo zde - [Only registered and activated users can see links Click here to register]
1xRPi2B → LibreELEC 8.0.2 → Kodi 17.3 \ 2x PC → Windows 10  → Kodi 17.3
[Only registered and activated users can see links Click here to register]
 
Citovat
#3
Takto postupuji a bohužel bez úspěchu.

Videa > Soubory > Přidat videa... > Vyhledat > Přidat síťové umístění.

Protokol nechám na SMB
Název serveru: IP Adresa
Sdílená složka: Název sdílené složky
Uživatelské jméno a heslo také vypisuji správně, to jsem ověřoval.

Po odeslání mi prakticky ihned vyskočí hláška "Connection timed out"

Takže zkusím přidat znovu a nezadávám IP a názvy, ale přepnu hned tlačítko Vyhledat. Zde se mi vyskočí název pracovní skupiny WORKGROUP. V mé síti jsem všude používal název pracovní skupiny GOOO, ale dnes jsem i všechny stroje v síti přiřadil do skupiny WORKGROUP. Přesto vždy, když dám vyhledávat ve WORKGROUP, tak mi vyskočí chybové okno s "Invalid argument"

Zkoušel jsem nasdílet složku na mém NTB a KODI ji také nijak nenajde, takže jsem pravděpodobně vyloučil problém v nastavení MM. Zbývá tedy problém v KODI, nebo v TURRISU. Nemá někdo nějaký tip?
 
Citovat
#4
Jen takovy dotaz - z pocitace se na ty disky na MM dostanes? 88
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) + 32 GB SD card & Raspberry Pi Zero
MacBook Air 13" - i5, 8GB RAM, macOS + KODI 17.3
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + KODI 16
iPhone 7 128 GB v10.3.1 nonJB CZ & Apple Watch 2 Nike+ v3.2.2
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
#5
Ano

Z počítače se na disky MM dostanu bez problému. Včera jsem se pokusil vyloučit některé problémy:


Abych vyloučil problém se sdílením v OS X, tak jsem nasdílel jednu složku ve svém NTB (W10). KODI ani v tomto případě nenajde žádnou složku a opět "Connection timed out" a "Invalid argument". Takže problém by snad neměl být v MM.

Vyhrabal jsem starší HWAP, abych vyloučil problém s Turrisem. Zapl na HWAP DHCP a přiřadil mu IP 192.168.1.1., připojil kabelem MM (od DHCP dostal 192.168.1.2.) a raspberryPi (dostalo od DHCP 192.168.1.3.). Ani v tomto případě se mi nepovedlo se připojit na sdílené disky. Přidal jsem pak i NTB se sdílenou složkou a také bez úspěchu.

Tedy jsem pravděpodobně vyloučil sdílení a routování. Tedy problém asi opravdu v KODI. Nyní mám OSMC, protože je řešeno instalátorem z Win. Koukal jsem, že má spousta uživatelů LibreElec a OpenElec, tak se pokusím nějak nainstalovat na kartu jeden z těchto systémů. Jinak, v OSMC vidím správně přidělenou IP adresu a masku.

Večer jsem rychle nainstaloval ještě Rasplex a ten jede normálně
 
Citovat
#6
Ja pouzivam OpenELEC a naprosto bez problemu, takze kdovi jak.
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) + 32 GB SD card & Raspberry Pi Zero
MacBook Air 13" - i5, 8GB RAM, macOS + KODI 17.3
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + KODI 16
iPhone 7 128 GB v10.3.1 nonJB CZ & Apple Watch 2 Nike+ v3.2.2
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
#7
Tak jsem nainstaloval OpenELEC a jediné co se změnilo je, že se v chybové hlášce chybí "Broken Pipe" :o/
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)