• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Zdravím hosta! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
O verzích aneb poučení z výpadku Stream-Cinema
#1
Velmi často, a nejčastěji při nějakých otřesech, jako byly vloni problémy se Sosáčem nebo letos, či vlastně včera, problémy se Stream-Cinema, se na fóru rozjede diskuse v počtu větším než malém. Je to občas humorné, občas nudné, jindy až tragické, číst ty nářky a výlevy o tom "jak jsem to celé smazal, naformátoval, přeinstalvoal a ono to stále nefunguje". Což o to, je to asi normální. Lidé panikaří, neví co se děje, dají na kusé zprávy a stále mají víru v to, že autoří se na to podívají, tu něco utáhnou, tu povolí a ono to zase pojede jak má. A přitom by stačilo tak málo. Věcné konstatování, zpětná vazba, aby autoři věděli co se děje a pak už jen trpělivé čekání, až to zase "posadí na koleje". Ale to ani náhodou. Desítky opakujících se postů s popisem celého chování rozeseté po celém fóru od včerejšího večera, kdy to ještě jelo, velmi často ale neobsahující relevantní informace, které by autorům k něčemu byly. A mezi nimi poměrně značná část těch, ze kterých nakonec vypadne, že "já tam mám nainstalovanou verzi 18" nebo že "už dva roky jedu na verzi 16, ale do včerejška mi všechno jelo dobře." V té chvíli se sám sebe, a teď tedy i ostatních, ptám. Co vede někoho, kdo stěží ví jak nainstalovat Kodi a pokud k tomu nemá video návod, tak to ani pořádně nedokáže, instalovat si poslední night build verze 18, která se momentálně nachází v alfa fázi vývoje? Nebo proč někdo provozuje prastarou verzi, dnes už pomalu "mínus druhou", ale stále si do ní instaluje novější a novější verze addon ve víře, že to přeci, "když už mi to bez upgrade běží skoro dva roky, musí běžet i nadále!"

Zastávám názor, že každý, kdo neupgraduje svůj systém a něco mu přestane fungovat, měl by si nejprve přečíst všechny changelog-y od té verze, kterou provozuje až do té aktuální, jestli v nich nenalezne řešení svého problému. Pak by si měl upgradeovat na aktuální verzi a pokud ani to nepomůže, měl by se teprve začít ptát. Jasně, existují výjimky. Jak směrem k novým verzím, tak k těm starým. V první řadě to jsou omezení dané HW a operačními systémy. Chápu ty, co si pořídili nový XBox, že si na něm nainstalují Leiu. Jinak to prostě nejde. Ale takoví lidé si toho jsou vědomi a pokud už se ptají, mají na to zvláštní subfórum, případně si jsou vědomi, že se nejedná o úplně standardní situaci a že je možné, že jim nikdo moc poradit nedokáže. Pak jsou tu nadšenci, kteří prostě chtějí být vepředu. Ti jsou té první skupně dost podobní, ale nejednají z nutnosti. Spíše z pocitu dobrodružství a jakési touhy mít něco extra. Za jakoukoliv cenu. I oni si jsou většinou svého excentrismu vědomi. Třetí skupina, to jsou lidé, kteří potřebují nebo chtějí být připraveni. Autoři addonů, skinů nebo ti, kteří se cítí být vůdčímu duchy svých komunit. Ti se většinou na nic neptají, a když už, tak většinou odpovědi hledají na fóremch příslušných platforem nebo přímo originálního Kodi.

Zamyslete se všichni, kteří provozujete prastaré verze nebo naopak ti, kteří co týden stahují nové nightbuildy alfa verze Kodi 18, aniž byste k tmu měli skutečně racionální důvod. Ano Kodi je složité, dnes někdo dokonce na fóru napsal, že je to "sračka", s čímž já samozřejmě nesouhlasím. Je složité to ano a samo o sobě může být zdrojem mnoha problémů. Proč si to ještě komplikovat tak, že budeme možné problémy násobit tím, že provozujeme verze, o který ani netušíme, co všechno skrývají (ty nové) nebo co v nich chybí (ty nové i ty staré). A když si už nemůžete pomoci, dejte to ostatním na fóru vědět. Stačí si přečíst pravidla a chovat se podle nich. Napovím... Podpis a v něm informace o vašich sestavách - HW, operační systém, Kodi, případně skin, ... To úplně stačí. Nejen jako informace pro ostatní, ale také jako vaše vizitka. Já osobně uvažuji o tom, že tomu, kdo nebude mít v podpisu takové informace nebo je alespoň v nějaké stručné formě nenapíše do svého dotazu, odpovídat už nebudu.
Client/TV Server: Asrock Beebox+LE 8.2.5+Tvheadend 4.2 (4x DVB-T UPC - 7 MUX/51 kanálů, OTT - 285 MUX/Kanálů),  Clients: RPi 2+LE 8.2.5 2xW10+Kodi 17.6, Android Mobile+TVHClient+Yatse NAS: Asustor
 
Citovat
#2
Naprosto souhlasím  Thumbup
3x RPi2B → L8.2.3 \ 1x RPi3B → L8.2.3 \ HTPC → L8.2.3 \ Xbox ONE S  18 \ X96 - S905X 2/16 → LE 8.2.3 \ NAS Synology 212J → DSM 6.2
 
Citovat
#3
Napsane sice dobre, ale zkusim se zeptat jako laik, proc ma proboha stream cinema co tri dny nejakou novou verzi u ktere vubec nepoznam nejakou zmenu.
 
Citovat
#4
A nemel bys tento dotaz spise polozit autorovi a v prislusnem tematu?
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) + 32 GB SD card & Raspberry Pi Zero
MacBook Air 13" - i5, 8GB RAM, macOS + KODI 17.3
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + KODI 16
iPhone X 256 GB v11.4.1 nonJB CZ & Apple Watch 3 Nike+ v4.3.2
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
#5
@creck preco je tomu tak dovod ma, snad si nemyslis ze autor to robi bezdovodne? Kazdopadne ti neodpoviem lebo ak polozis takuto otazku je zbytocne ti to vysvetlovat, bez urazky.

@Jiro thumbs up, skoda ze si toto aj tak precita minimum ludi ktorych sa to tyka.

Howk
Lame truper 1.2,
Jody 16.2
 
Citovat
#6
@creck: odpověď najdeš právě v changelogu. Ne každá změna musí být viditelná, nebo je viditelná jen při určité konfiguraci. Jiro má pravdu a pod takový článek se klidně podepíšu i já.
LE 8.2.1, Kodi 17.6   + RPi 3B
LE 8.0.2, Kodi 17.3   + RPi 2B
Kodi 17.6 + Win10Pro InsiderPreview + virtual PC
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#7
@JiRo - uz jsem myslel, ze to je pouceni z krizoveho vyvoje :-) , ale obecne a ze zkusenosti plati, ze to tak zkratka je a zmeni se v budoucnu jen velmi malo , takze je potreba setrit sily na neco smysluplnejsiho :-)
sz nectu, na dotazy pouzivejte forum, mozna tak pomuzete ostatnim
 
Citovat
#8
I z toho důvodu, že nikdo nic nečte a všichni si představují že budou mít vše zdarma v prémiové kvalitě, se autorovi vůbec nedivím, že nebude deset let držet zpětnou kompatibilitu API, když má napsané nové.. Proč by to dělal, že jo :)
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)