• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Zdravím hosta! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Raspberry nevidím v síti
#1
Ahoj, 2 dny mi běželo Pi3 v síti. Tedy aspoň jsem ho viděl v Pc a mohl jsem kopírovat filmy z Pc na disk připojený k Pi3. Včera se něco podělalo a zničeho nic nevidím Pi3 v síti. Když na něj pošlu přes příkazový řádek ping tak odpoví. Když v průzkumníku zadám jeho IP tak se objeví a vidím všechny složky Pi3 i připojené disky. Měl jsem v síti i noťas a taky ho nevidím. Už jsem prostudoval vše na netu a nic mi nepomohlo. Už si nevím rady. Zkoušel jsem i nasdílet složku nebo celý disk v Pc a najít ji v Pi3. To jsem našel, ale když jsem to chtěl otevřít tak to po mě chtělo přihlašovací jméno a heslo, ale nic jsem nezadával, takže ani nevím co tam zadat
 
Citovat
#2
A co restart routeru,popř.RPi,ale může tam být víc problémů, a co nastavení v systemu toho RPi ... 9



 
Citovat
#3
Počítám, že na PC máš Windows 10. Ty s tím mají evidentně problém, řešilo se to tady - [Only registered and activated users can see links Click here to register],
ale obecné univerzální řešení asi není. Mě se po čase vše objevilo, bez nějaké zjevné příčiny.
1xRPi2B → OpenELEC  6.0.3 → Kodi 15.2 \ 2x PC → Windows 10  → Kodi 16.1
[Only registered and activated users can see links Click here to register]
 
Citovat
#4
Tento čtvrtek jsem měl úplně stejný problém. Malinu, ale ani NAS jsem jako síťové zařízení neviděl v žádném zařízení mimo Linuxu. Přes webové rozhraní i přes SSH jsem se přitom k oběma připojil, ale to jsou jiné porty a protokoly. Ping také fungoval, takže obě zařízení v síti byla. Na důvod jsem nepřišel, ale preventivně jsem restartoval router. V mém případě to byl jediný společný bod. V pátek jako zázrakem bylo všechno zpět.
Pokud se s tím setkal ještě někdo a našel odpověď, budu rád.
Openelec 6.0.3 + Raspberry 2B
Kodi 17beta6 Krypton + Win10Pro InsiderPreview +  virtual PC
Kodi Jarvis + Lenovo Yogatablet 10 FHD + Android
Kodi Jarvis + NB Lenovo ThinkPad E540 + Win10Pro
NAS Synology 215j 3TB Raid1
Router Turris
 
Citovat
#5
Ano mám win 10. Restart maliny proběhl snad 20x. Router jsem zkoušel jen 1x. Když se podívám n routeru na DHPC tak tam vidím 2x LIBREelec a má 2 různé IP adresy. Když jsem se podíval do správce systému tak je tam v tom stromečku položka další zařízení a po rozkliku je tam síťový adapter a multimediální zvukový adapter a u obou jsou žluté vykřičníky. Předpokládám že by to mojla být malina, protože hned pod touhle položkou bylo staré centrum WD Tv live

(29.10.2016, 19:36)PetrM Napsal(a): [Only registered and activated users can see links Click here to register],
ale obecné univerzální řešení asi není. Mě se po čase vše objevilo, bez nějaké zjevné příčiny.

Zvlátní je, že jsem tady na foru hledal nějak téma o tomhle problému a nic jse nenašel. Díky vyzkouším to co ta dal Rossi
 
Citovat
#6
Ráno jsem zapl Pc i Malinu a hle ono to zase funguje. Zase vidím Malinu v síti
 
Citovat
#7
Ahoj, tak jsem přišel na jednu věc proč se mi ztrácí Rpi3 ze sítě. Když se podívám do routeru TP link 1043 do DHCP clien list tak je tam položka Libreelec s MAC a IP adresou. Pokud tam je jen jedna položka Libreelec tak je to v pořádku a Rpi3 v síti vidím. Jenže po každém restartu Rpi3 nebo routeru dostane Rpi3 jinou MAC a IP adresu a v DHCP roteru se pak vytvoří další položka Libreelec. Měl jsem tam i 4 položky Libreelec a každá měla jinou MAC a IP adresu a mám takový dojem, že pak má systém problém se připojit.
 
Citovat
#8
Tak pokud se zmeni MAC, tak logicky DHCP prideli jinou IP a ty se nepripojis, protoze zrejme pristupujes na starou IP.

EDIT: zkus jeste procist tohle:
> [Only registered and activated users can see links Click here to register]

Nicmene urcite to neni normalni chovani.
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) & 32 GB SD card
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + Kodi 16
iPhone 7 128 GB v10.1.1 nonJB CZ & Apple Watch v3.1
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
#9
Tak jsem provedl již druhý reinstal Win10. První v pátek a Pi3 v sobotu byla vidět. Někdy jsem musel zadal do adresního řádku v pruzkumníku \\Libreelec abych viděl disky, ale večer se něco opět naštvalo a a nepomohl ani adresní řádek a vyskočila hláška "Položka libreelec není přístupná. Zřejmě nemáte dostatečná opravnění pro přístup k této položce. Obraťte se na správce servru a ověřte oprávnění. Zadaná přihlašovací relace neexistuje. Zřejmě již byla ukončena."
A s touhle hláškou si hakt nevím rady co s tím. Dnes ráno jsem kvůli te hlášce udělal znova reinstal Win10 a opět vše fungovalo asi do 18.00hod. kdy opět vyskočila tahle hláška. Tohle přeci není možné aby se to takhle pořád kazilo a nechtělo to vůbec komunikovat s Pc. 12 12 12 12
 
Citovat
#10
Zacal bych aktualizaci fw toho TP linku...
 
Citovat
#11
RPi musí mít v routeru stále stejnou MAC adresu, i když se změní IP adresa. Jedno zařízení musí mít jen jeden DHCP záznam. Tam hledej chybu. Zaveď si rezervovanou jedinou IP pro RPi. A a změna MAC je velká chyba, to musíš vyřešit.
OpenELEC-Kodi 16.1.RC3 > RPi2 > Samsung LED46. BerryBoot-LibreELEC-Kodi 16.1.RC3 > RPi3 > LED32. SD 8GB Kingston (10) + USB Kingston G2. Kodi na NB HP 15" s W7-32bit. Kodi na LinuxMint PC.
 
Citovat
#12
Presne tak, nesmyslnym preinstalovavanim Windows nic nevyresis, pokud se ti RPi porad identifikuje ruznou IP adresou, tak je logicke, ze se na nej nepripojis. Pokud se opravdu meni MAC adresa, tak bych volil cestu toho, ze bych v RPi nastavil nejakou IP natvrdo (static).
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) & 32 GB SD card
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + Kodi 16
iPhone 7 128 GB v10.1.1 nonJB CZ & Apple Watch v3.1
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
#13
Tak jsem u DHCP dal Pi3 adresu natvrdo. Měl 2 připojení. Jedno přes wifi a druhé přes kabel. Wifi jsem odpojil a nechal jen kabel a dal mu permanentní adresu. Už se objevil i v síti, ale pořád když kliknu na ikonku Libreelec v síti vyskočí zase ta hláška o nedostatečném oprávnění. Udělal jsem i reinstal PI3 a nic. 17

PS: Tak se zdá, že asi vyřešen problém s tou hláškou. Měl jsem nasavenou Veřejnou síť místo Privátní. Když jsem to převedl, Librelec naskočil. Tak doufám že to bylo ono.
 
Citovat
#14
No to nevim, jestli se to vyresi, pac jestli jsi mel nastavenou verejnou sit, tak jsi nemohl videt okolni zarizeni v siti, tudiz ani tu ikonu Libreelec...
 
Citovat
#15
Však ano, já jsem nic neviděl. Jen občas naskočila ikona Libreelec. Po předělání na privátní ihned naskočila ikonka do sítě mého pc i ikonka libreelec a mohl jsem se dostat i na zen disk co mám připlý k malině, protože ta hláška už nevyskočila
 
Citovat
#16
Obecne, co rozhrani, to jak MAC adresa, tak i IP adresa. Pokud tedy mas wifi i kabel, tak je logicke, ze je zarizeni dosazitelne na (minimalne) dvou IP adresach.
2x Raspberry Pi 2B - OpenELEC v6.0.3 (KODI 15.2) & 32 GB SD card
Asus EEE Box EB1501U - Atom N330 (1.6 GHz), 4GB RAM, nVidia ION, W10 Pro + Kodi 16
iPhone 7 128 GB v10.1.1 nonJB CZ & Apple Watch v3.1
iPad Air 2 128 GB v9.0.2 JB CZ (KODI 15.2)
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)