XBMC-Kodi.cz

Úplná verze: Armbian v TVboxe
Prohlížíte si holou variantu vašeho obsahu. Prohlédněte si plnou verzi s příslušným formátováním.
Ahoj, zo zvedavosti som chcel vyskúšať armbian 5.73 na vorke z6+. Desktop nejde obraz, tak mám server, ten funguje.
Takže plán bol takýto : niečo na ip kamery, nextcloud, transmission, homeasistant, openhab.

Po 6 dňoch sa mi podarilo rozbehať motioneye na tie kamery, viac nič. Pri ostatných vždy na niečo narazím alebo to aj ide ako tak ale po reštarte už nie...homeasistant.

Dúfam že tu nájdem ľudí ktorý budú ochotný mi s tým trochu pomôcť :)

Síce to má s kodi spoločné málo ale sú tu ludia ktorý sa zaoberajú chytrou domácnosťou, linuxom a je to možno jediná komunita czsk ktorá sa venuje tv boxom. Tak lepšie miesto na moje otázky si myslím ani neexistuje :)

Ďakujem.

Teraz sa snažím rozbehať openhab xtý krát. Najskôr som použil java64bit, stránka sa nezobrazila. Teraz mám 32bit javu a výsledok rovnaký. Myslím že tá java tam je ale nefunguje.
Kód:
[18:36:21] root@aml:~# apt-get install zulu-embedded-8
Reading package lists... Done
Building dependency tree
Reading state information... Done
zulu-embedded-8:armhf is already the newest version (8.25.0.76).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
[19:24:16] root@aml:~# java -version
Illegal instruction
[19:24:23] root@aml:~# update-alternatives --config java
There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/zulu-embedded-8-armhf/bin/java
Nothing to configure.
[19:24:28] root@aml:~#
Tak openhab uz funguje, sice na 64bit oracle java ale funguje. Zulu java som nerozbehal zatiaľ.
Kdo si hraje,nezlobí ;) a zaklad máš zde:
[Only registered and activated users can see links Click here to register]
Ďakujem :)

P.S. zapnem box a tam toto :
azza@aml:~$ sudo
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set
azza@aml:~$ su root
Password:
su: Authentication failure
root@aml:~# sudo
sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
sudo: /usr/lib/sudo/sudoers.so must be owned by uid 0
sudo: fatal error, unable to load plugins

už som to mal viac krát, googlil som čo s tym ale nič. Dá sa to opraviť alebo zakaždým nová inštalácia?
Těd zrovna nemám moc času,ale místo "su root" použij "sudo su" .
Budeš přihlášen jako root a sudo nemusíš používat.
uprav si co chceš.
exit
To áno, len čo som googlil tak som stratil permission k rootu.
Sudo, su, sudo su, sudo - i samé chybové hlášky.

Tak nainštaloval som ubuntu na pc a pokračujem tam, kym nenajdem aml912 distro čo nebude blbnut z root právami :)

1..Rozbehol som nextcloud ale za nic sa na neho z mobilu nepripojim, kde môže byť problém? V rovnakej sieti.

2..iscsi som vytvoril v NAS, ale z linuxu sa nepripojim nech skusam co skúšam.

Za ten čas čo sa tu trápim v ubuntu by som z windows vytvoril it centrum :)
Teď se mi v tom nechce hrabat abych ti poradil,ale na telefon si stahni aplikaci pro síť:
"Fing - Network Tools"
a pro SSH:
Termius - SSH/SFTP and Telnet client. To ti jistě usnadní bádání.
Fing mám, a porty som nasiel len 22 a 10000, ani jeden nie je nextcloud. Firewall je vypnutý.

Už to ide ale nastaviť prístup z vonku a aj to zabezpečiť to už chce linux čarodeja :)
1. Openhab a home assistant idú v docker. Na odskúšanie je to fajn.
2. Iscsi disk mi nejde pridať nech robím čo robím. Ako to mám nastaviť?
3. Ako by som server pripojil na internet, ak mám doménu a stránku tak by to šlo cez subdomenu alebo potrebujem nejakú službu na to?
Ďakujem [Obrázek: 8215b68a00c5abca1b9ddafececa89f6.jpg][Obrázek: d30466b918bbf5492adefc7d0c4f25eb.jpg][Obrázek: 645933ad7e4b5aac5d3a1d23e820d0e1.jpg]
Hass v docker vlastne nešiel, nefungovalo pridávanie, konfigurácia služieb.

Aktuálne na vorke z6 beží armbian 5.78 server Ubuntu 18.04.2 lts.
LAMP, WordPress, Nextcloud... prístupné je jedno alebo druhé, obe súčasne nie. Ak zadám sudo a2ensite wp.com alebo next.com tak funguje bud jedna alebo druhá. Čo s tým? Skúsil som už niekoľko postupov.
Home assistant, samba, iscsi disk, portainer a docker, cups.
Nagios, nainstaloval sa ale nie celkom tak beží len z časti, čo miesto neho aby fungovalo korektne na arm64 a malo apku v androide?
Toto nastalo hned po spustení apt upgrade, pred tym strata root oprávnení. Ako zistím prečo sa to stalo? Či to je boxom alebo armbianom? Skúšal som ubuntu aj na pc a tam také problémy neboli.

Je nejaký balíček ktorym spravím zálohu a obbovu buď z usb na sd alebo nas? Aby to fungovalo ako bod obnovenia vo windows ale môže byť aj obraz disku. Ďakujem. [Obrázek: de824276a7f4de9bdb5c15b1b99b6b97.jpg][Obrázek: ba1312d111451685cb45f3d694723697.jpg]
Ani nevím jestli se k tomu dostanu...
Mrkni na [Only registered and activated users can see links Click here to register]
@plesi, pozrel som pred tym jeden podobný a tam píšu že po obnovení majú všetky súbory a priecinky len z pristupom root. A že treba ich manuálne nastaviť. To na všetkých tychto sw? Lebo to je šialená vec :) dnes som dal najnovší armbian a nikam som sa nedostal, stále nejaký problém. Asi to bude v tom armbiane nakolko CE ide pekne stabilne. .
Nevím...musel bych to otestovat,ale není moc času na hraní Undecided i hrátky s NanoPi R1 musím odložit asi až na příští víkend.
Nezbude než hledat na google.

Já když jsem potřeboval root tak stačil příkaz "sudo su".
To áno, ale tu aj root stratil opravnenie root :) a to som sa nahladal, naskúšal ale pomohol až rufus. Ako ak sa to stane hneď keď naštartuje nová inštalácia to sa ešte dá. Ale keď instalujes, konfigurujes a guglujes 14 hodín... to sú tie chvíle keď sa nwm rozhodnúť či vyhodím z okna pc alebo rozdupem tie magic boxy :)