• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi 19.1 náhle zamrzá na cca 20 vteřin (čistá instalace)
#1
Mám nový Asus PN50 s čistou instalací Windows 10 se všemi update, nejnovějšími ovladači a čistou instalcí Kodi 19.1. I přestože je Kodi nově nainstalován, tak sám od sebe zamrzá (zmrzne jen Kodi, zbytek systému i procesor jede bez větší zátěže)

Tady je první debug log, kde freeze začíná na 2021-09-10 21:37:09.562.
Tady je další debug log, kde freeze začíná na 2021-09-10 21:33:49.425

Prosím pomozte mi najít problém. Sám nevím, kde a co vůbec hledat :/

edit: Zkusil jsem i Kodi 18.9 a děje se to samé Sad
 
Citovat
#2
@Def: Zatím se jen zeptám - Čistá instalace znamená, že jsi se podíval na adresáře, které vznikají při instalaci Kodi a vymazal je po jeho odinstalaci?
https://www.xbmc-kodi.cz/prispevek-adres...ubory-kodi
Které Kodi z downloadu instaluješ? Předpokládám EXE verzi 64bit, ne tu ze Store...
https://kodi.tv/download/windows

Co je to u tebe "Custom_1100_AddonLauncher"? ...v čisté instalaci....?

Co bývá ve Win problém... Nekompatibilita s virtuálním síťovým adaptérem.
Proces SW (antivirus, indexace, zálohováni), který znemožní přístup k nějakému adresáři, souboru, který Kodi potřebuje použít.
Kodi 19/18.x -LibreELEC 10/9.x -BerryBoot -RPi4/3/0/w -LinuxMint21/W10/Android11. Router 1Gbit 2.4+5GHz
 
Citovat
#3
Po instalaci jsem vzal adresář AppData\Roaming\Kodi a ten jsem smazal.
Instaloval jsem verzi z kodi.tv (.exe), na Store jsem vůbec nebyl. Měl bych?

"Co je to u tebe "Custom_1100_AddonLauncher"?" Uff, nevím jak odpovědět. Jestli to tam být nemá, tak jsem možná jen uploadnul logfile ještě s mým "starým" Kodi, které jsem používal před čistou instalací. Případně pošlu další log.

Ad tipy na časté problémy. Díky, zkusím. Každopádně přijde mi to divné... Doposud Kodi provozuji na řadě zařízení a nikde se mi tohle nedělo. Takže antivir, indexace, zálohy mi do toho moc nesedí, ale neříkám, že to tak být nemůže.

Virtuální síťový adaptér - to zní zajímavě. Jak můžu vyzkoušet, jestli není problém tady?
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#4
No otevřeš okno Windows, Ethernet /Centrum síťových připojení /Změnit nastavení adapteru a tam je třeba Hamachi. Ten ovšem zabíjí Kodi až při tahání že sítě.

Ty adresáře Kodi (exe) jsou víceré.
Windows 10
KODI - %PROGRAMFILES%\Kodi\ tedy C:\Program Files\Kodi\ nebo %PROGRAMFILES(x86)%\Kodi\ tedy C:\Program Files (x86)\Kodi\
HOME - %APPDATA%\Kodi tedy C:\Users\<USERNAME>\AppData\Roaming\Kodi\
TEMP (umístěn v HOME) - %APPDATA%\Kodi tedy C:\Users\<USERNAME>\AppData\Roaming\Kodi\cache\
LOG (umístěn v HOME) - %APPDATA%\Kodi\kodi.log tedy C:\Users\<USERNAME>\AppData\Roaming\Kodi\kodi.log
Pozn. Při jiné konfiguraci může být místo C: použita jiná disková jednotka


EDIT: Instalace ze Store dřív zlobila ale teď mám 19.0 a na W10 mi funguje dobře. Má zas jiné adresáře k nalezení.
Kodi 19/18.x -LibreELEC 10/9.x -BerryBoot -RPi4/3/0/w -LinuxMint21/W10/Android11. Router 1Gbit 2.4+5GHz
 
Citovat
#5
Znovu díky!

Hmmm, nechtěl bych předčasně slavit, ale vypadá to, že by to mohlo být něco s tou sítí. Vypnul jsem adaptéry BT, WiFi a LAN a během dvou minut klikání v menu KODI se mi to ani jednou nehryzlo (což se dříve dělo). 

Pokud by byl problém zde, jak to řešit? Přece jen na síti bych s tím potřeboval :o)
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#6
Upřímně, nevím. Nevím, kde je chyba.
Vyzkoušel bych opravdu čistou instalaci a třeba i z toho Store, jen je potřeba si dát práci s vyčištěním/odstraněním všech původních adresářů Kodi.

(Čistá instalace W10 na novém NB ASUS znamená, že firemní instalaci jsi zrušil a udělal novou čistou bez reklamního a podobného SW od ASUS?)
Kodi 19/18.x -LibreELEC 10/9.x -BerryBoot -RPi4/3/0/w -LinuxMint21/W10/Android11. Router 1Gbit 2.4+5GHz
 
Citovat
#7
@Def & @meda Na logy jsme se díval, snažil jsme se tomu přijít na kloub, ale moc mě toho nenapadlo. Věnoval jsem tomu ale příliš málo času, tak snad později, až ho budu mít více. Přesto dvě poznámky k proběhlé diskusi:
  • Tohle se na Windowsech stává, sám s tím občas bojuji, řekl bych, že to závisí na nastavení prostředí OS. Dvě identické instalace Kodi 19 na dvou W10 počítačích, u jedné se to stává občas u druhé nikdy. Ale je to jen dojem, nikdy jsem po tom podrobně nepátral, protože Kodi na těchto počítačích používám teď už zřídka, vlastně už skoro vůbec ne. 
  • V existenci souboru Custom_1100_AddonLauncher problém nehledejte, to je standardní součást skinu Estuary.
A ještě jedna nakonec. Už dříve jsme měl podezření, že by to mohlo souviset s nějaký timeoutem při načítání souboru, který nemá Kodi správně ošetřený přímo, takže tam proběhnou nějaké další delsí timeouty na vyšší úrovni a v jejich důsledku jádro Kodi shodí nějaké thready, a poté se to znova rozjede. Tomu by odpovídalo to chování v okamžiku, kdy @Def shodil síť. V tom případě Kodi pokus o otevření souboru vzdá hned a nebo, což je možná pravděpodobnější, díky tomu že Kodi nemá přístup k síti, tak se do téhle sitiuace ani nedostane.

@Def Tady by asi pomohlo nahlášení problému teamu Kodi na kodi.tv. Jen si dej pozor, abys v logu neměl info o používání banovaného repozitáře nebo addon. To by s tebou hned vyběhli.
 
Citovat
#8
@meda: ano, počítačl byl prodáván bez OS, takže jde o čistou instalaci Win.
@meda & @JiRo: Tak bohužel po zapnutí LAN adaptéru a/nebo WiFi adaptéru je problém ihned znovu. Dobré, když ho zakážu, tak se kodi ihned "odsekne" a jede dál. Tzn. část problému je identifikována, ale řešení v nedohlednu :/
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#9
@Def: Pro zajímavost - jak se to bude chovat, když v Kodi nastavíš pouze ruční vyhledávání aktualizací bez informování o jejich existenci.
Kodi 19/18.x -LibreELEC 10/9.x -BerryBoot -RPi4/3/0/w -LinuxMint21/W10/Android11. Router 1Gbit 2.4+5GHz
 
Citovat
#10
@meda: pokud myslíš Nastavení/systém/doplňky/aktualizace - tak to už jsem zkoušel. I když nastavím "nikdy nekontrolovat aktualizace", tak to stále mrzne :/
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#11
@Def Tak ještě jeden pokus, ale bude to vopruz. Zkus postupně zakazovat jeden doplněk po druhém.
 
Citovat
#12
Jen střelba od boku, zakázat po startu aktualizaci knihovny ?     
S905X 2/3 → CE 19 \ RPi4 → LE 19 \ HTPCLE 18 \ XOne S  18 \ NAS Synology 212JDSM 6.x \ Vero 4K+ → OSMC 19
 
Citovat
#13
@Rossi D: beru všechno - i střelbu od boku :) Tu mám zakázanou. (edit - zakázanou mám aktualizaci knihovny, ne střelbu od boku :)

@JiRo: Uff, nevím jak to myslíš "zakazovat". V čisté instalaci Kodi není lze zakázat maximálně ovládání xboxovým ovladačem. Všechny ostatní doplňky nemají možnost "zakázat". Btw - všiml jsem si, že Kodi se mi se sítí spouští cca 30 vteřin. Bez sítě je spuštěné za vteřinu...
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#14
Tak to mi opravdu připadá jako "práce" W-Defenderu ....  19
S905X 2/3 → CE 19 \ RPi4 → LE 19 \ HTPCLE 18 \ XOne S  18 \ NAS Synology 212JDSM 6.x \ Vero 4K+ → OSMC 19
 
Citovat
#15
@Def Jsi si jistý? Každý doplněk by měl mít v menu možnost Zakázat. Lze to provést na widgetu u položky Doplňky v havním menu (tedy pokud není nějakou závislostí, to ti pak Kodi zakázat doplněk nedovolí), a pak by doplněk měl ze seznamu zmizet. Povolit doplněk pak ale můžeš ve widgetuu pouze přes Moje Doplňky nebo přes Nastavení, kde bude mít v seznamu u zakázaného doplňku místo "fajfky" křížek.
 
Citovat
#16
Chlapi, moooožná jsem na dobré cestě... Kodi už startuje rychle a zásek zatím ani jeden. Po dlouhém hledání na internetu jsem objevil, že někdo měl podobný problém a důvodem byl nedostupný síťový disk. Zjistil jsem, že jak jsem zprovozňoval nový komp, tak se mi nenamapovalo jedno síťové úložiště. Když jsem to namapování zrušil, vše se jako zázrakem rozjelo.

Snad už tomu tedy bude konec. Kdyby ne, ozvu se. 

Každopádně prozatím díky moc a mějte se fajn!
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#17
To bude ono, problém se sítí. Přišels na to 1

EDIT: Někdy příspěvek zneviditelni dvě adresace uživatelů za sebou. Ale už's to předělal, je to vidět.
 
Citovat
#18
divné, že se moje zpráva neobjevila... doplnil jsem ji znovu. Snad moje zkušenost pomůže budoucím generacím :o)
ASUS PN 50 Windows 10. Ext HDD 6TB (USB 3.0) NTFS, Kodi 19.1
 
Citovat
#19
@Def: Hlavně by mělo pomocí budoucím generacím pochopení, že je potřeba uvádět vsechno (netvrdím, že bych věděl co s tim). Teď poprvé jsi zmínil, že
Kodi už startuje rychle...
...a já se ještě zeptám - To namapovani jsi měl v systému W10 nebo jen v Kodi?
Kodi 19/18.x -LibreELEC 10/9.x -BerryBoot -RPi4/3/0/w -LinuxMint21/W10/Android11. Router 1Gbit 2.4+5GHz
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)