• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Kodi spadne lubuntu 18.04
#1
Bug 
kodi
Exception TypeError: "'NoneType' object is not callable" in <bound method SimpleCache.__del__ of <resources.lib.simplecache.SimpleCache object at 0x8a6fc04c>> ignored
Exception TypeError: "'NoneType' object is not callable" in <bound method SimpleCache.__del__ of <resources.lib.simplecache.SimpleCache object at 0x8b50b88c>> ignored
Exception TypeError: "'NoneType' object is not callable" in <bound method SimpleCache.__del__ of <resources.lib.simplecache.SimpleCache object at 0x8817822c>> ignored
Exception TypeError: "'NoneType' object is not callable" in <bound method SimpleCache.__del__ of <resources.lib.simplecache.SimpleCache object at 0x89ed96ec>> ignored
Segmentation fault (core dumped)
Crash report available at /home/petr/kodi_crashlog-20180425_092844.log


https://webshare.cz/file/3oh5h65j17/kodi...131935-log
https://webshare.cz/file/4j91LPh0xq/kodi...142744-log
https://webshare.cz/file/16l6TvcG79/kodi...092811-log
https://webshare.cz/file/6eI6Fr1t14/kodi...092844-log

Zkoušel jsem poprosit o radu (zatím bez úspěchu) i zde, je tam i výpis info o PC :
http://forum.ubuntu.cz/index.php?topic=83335.0
 
Citovat
#2
Citace z jiného fóra, kde jsi napsal: Ahoj. Neumím to (reportovat vývojářům) a neumím anglicky.
Mylsím si že to nebude tím že to je připravovaná verze 18.04, která je už skoro hotová, ale spíš si myslím že bude problém v kombinaci kodi, lubuntu a tento HW..


Verze Beta je pořád BETA. Tím sami vývojáři říkají, že není dotažená. Jednoduše počkej na plnou verzi.

A navíc........tento dotaz nepatří sem, je tu přece podtitul
"Napište nám názor, chyby, nové nápady, zlepšení aj. týkající se tohoto fóra"

ale sem: Obecné otázky a dotazy http://www.xbmc-kodi.cz/forum-obecne-otazky-a-dotazy
"Nevíte si s něčím rady? Nenapadá vás vhodná kategorie pro umístění dotazu? Napište svůj dotaz sem"
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#3
Plná verze vyjde zítra. Jsme přesvědčený že problém není v tom :)
Ale do zítra tedy zbytečně počkám, když si všichni myslí že to za den celé předělají Big Grin
 
Citovat
#4
Ano, je vidět, že nerad děláš zbytečné věci, jako například uvádět verzi instalovaného Kodi a způsob instalace a konfigurace.
Je docela možné, že to bude souviset s grafickou kartou a jejím ovladačem. Vyzkoušej, jestli Lubuntu nenabízí lepší.
Ještě uvaž toto z odkazu (bod 3.) http://www.xbmc-kodi.cz/prispevek-linuxm...8#pid19968
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#5
Když jsem použil ppa:team-xbmc/xbmc-nightly tak to funguje :)
Asi to tak nechám do doby než se to neporouchá a pak to případně změním na stable :)
Je tu PC u bývalého souseda který mu spravuji..

Zajímalo by mne, jeslti funguje nějaké automatické hlášení chyb ať už v kodi nebo lubuntu..
Aby případné problémy někdo viděl a mohl opravit.

A pro méďu. V logách samozřejmě jsou verze kodi a systému.
Je tam například:
13:18:28.859 T:2921361536 NOTICE: Starting Kodi from Debian (17.6 Debian package version: 2:17.6+dfsg1-1ubuntu1). Platform: Linux x86 32-bit
13:18:28.859 T:2921361536 NOTICE: Using Release Kodi from Debian x32 build
13:18:28.859 T:2921361536 NOTICE: Kodi from Debian compiled from 2:17.6+dfsg1-1ubuntu1 by GCC 6.4.0 for Linux x86 32-bit version 4.15.15 (265999)
13:18:28.859 T:2921361536 NOTICE: Running on Ubuntu Bionic Beaver (development branch) 18.04, kernel: Linux x86 32-bit version 4.15.0-19-generic

A způsob instalace byl "https://kodi.wiki/view/HOW-TO:Install_Kodi_for_Linux" :)

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi
 
Citovat
#6
Tak to omluva, je to tam. Ale vycházej z toho, že info o tom, na čem, co, jak, je dobré uvést v textu a ne logu. Protože kdo chce pomoci se nejdříve podívá na základní info a řekne si, že buď to zná nebo nezná.
Jinak s tou verzí nightly dobré prozatímní řešení.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#7
@tja Nepochopil jsem o stabilní verzi jakého systému/aplikace mluvíš, která půjde "zítra" ven. Ale pokud o Kodi, tak by mne docela  zajímalo, kde ses to dočetl. Pošli odkaz. Pokud vím, tak nyní je venku (bavíme se o Leia) Alpha 1. Pokud tedy něco bude následovat, bude to Beta. Je možné, že team něco přeskočí (obča to dělá), ale divil bych se, protože v Leia je hodně zásadních změn. Určitě tedy bude nějaký RC, což pravda, je pro někoho už "stabilní verze".

Nesmíš však zapomínat na jedno. Více či méně stabilní může být vlastní Kodi. Ale co jeho addons?! Tedy hlavně ty, které nevytváří team? Řeknu to to asi takhle. Pokud budeš chtít teamu hlásit chyby, které máš v Alpha 1 verzi, a provozuješ na systému i addon, které nejsou oficiální, tak na to zase rychle zapomeň. S tím tě každý vývojář teamu pošle do háje.

Já se divím lidem, kteří nemají nějaký vážný důvod, že provozují nightbuildy, alphy a bety. Ještě tak RC, budiž, ale ani to bych někomu, kdo zprovozňuje Kodi sousedovi, nedoporučil.

A nakonec. Problém který popisuješ v první postu, možná, tedy spíše velmi pravděpodobně, souvisí právě s nějakým addon. Modul simplechace je populární a používá ho řada autorů addon, mezi jinými například i @BBaron ve svém Stream-Cinema. A vidím, že Stream-Cinema na tvém (sousedově) Kodi máš instalovaný a v provozu. Možná bych příčinu problému hledal tam. Zkus tento addon zablokovat a uvidíš, zda se chování Kodi změní.
 
Citovat
#8
@JiRo -On myslel verzi LUBUNTU, protože UBUNTU 18.04 LTS finální šla ven 26.4. Jestli už stabilní Lubuntu 18.04 LTS je k mání, nehledám.
 
Citovat
#9
@meda Jo jo, já si to myslel... :) I pochybnost jsem vyslovil, ale dál jsem pak už vycházel ze špatného předpokladu. U logů jsem si prohlížel víceméně hlavně jejich konce. Teď to vidím i v tom příspěvku s vloženým fragmentem logu.

Ale to je zároveň další důvod k tomu, oznamovat konfiguraci systému explicitně. Tak se @tja omlouvám za příkrost.

Ale na tu simplecache, resp. SC,  bych se podíval. Že by aplikace v pythonu shodila Linux, tomu se mi sice taky nechce věřit, ale správa paměti u pythonu se s problémy potýká, tak kdo ví.
Kód:
...
13:18:40.426 T:2294278976 WARNING: CPythonInvoker(3, /home/petr/.kodi/addons/plugin.video.stream-cinema/default.py): the python script "/home/petr/.kodi/addons/plugin.video.stream-cinema/default.py" has left several classes in memory that we couldn't clean up. The classes include: N9XBMCAddon4xbmc7MonitorE,N9XBMCAddon7xbmcgui6WindowE
...
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)