• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Nastaveni času
#1
Ahoj všem, poraďte mi prosím. Mám krabičku Nexbox A95 a na něm běží coreelec 9.2.3. Zaboha nemůžu nastavit v kodi správný čas. Mám nastavený správný region i všem okolo času v nastavení přes expert. Zařízení je online ale pořád ukazuje špatný čas a datum je leden 2015. Už jsem zkoušel i nastavit ntp server, ale s krabičkou to ani nehne.
Tím pádem mám problém hlavně s instalací doplňků a pvr.
Pište možnosti řešení. Je to krabička u rodičů kam jezdím jednou měsíčně tak ať mám víc možností co vyzkoušet.
 
Citovat
#2
Zkus box restartovat. V Androidu máš čas správně?

Edit: Coreelec sice nemám, ale v Libreelec v takovém případě doporučují najít volbu Počkat na připojení k síti před spuštěním Kodi. U sebe jsem to našel (v nastavení Libreelec). Volbu mám povolenu a nastaveno Čekat 10 sec.
X96max plus 4/32 + CE 9.2.5 + Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#3
Android nemám core je ve vnitřní paměti, ale to co píšeš jsem nastavil spolu s ntp a nic. Jinak restartu proběhlo.........
 
Citovat
#4
Tak to sorry. Jiný nápad nemám.
X96max plus 4/32 + CE 9.2.5 + Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#5
@mafian: Jsi, tedy rodiče, připojený k routeru? Jaký datum a čas běží na něm?
Někde také bývá volba  přebírat region/jazyk/čas přes CEC.
 
Citovat
#6
@mafian Kde ty NTP servery nastavuješ. V nastavení Síť nebo v nastavení Spojení. Default by to mělo být připraveno v nastavení Spojení, teoreticky bys tedy žádné NTP servery zadávat nemusel. Pokud jsi je zadával v nastavení Síť, tak je zkus vymazat a nechat jen ty, co jsou default nastaveny ve Spojení. Další věcí je jak a zda máš správně nastaveny DNS servery. Jak získáváš IP adresu, přes DHCP server nebo ji zadáváš ručně?

Už jsem instaloval a nastavoval desítky *ELEC systémů a nikdy jsem žádný problém s časem neměl. Vždy vše, co se týče NTP, nechávám default tak, jak je to nastaveno v části Spojení a funguje to vždy bez problémů.
 
Citovat
#7
@JiRo: To já kdysi testoval RPi2 s několika systémy na SD tak moc, že jsem čas rozházel nadobro (už se nesrovnal žádným resetem) a musel pak do nastavení NTP zapsat časové servery.
Ano, tenkrát to bylo ve "spojení" - systémy to mají různě.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#8
@JiRo:  server jsem nastavoval v nastavení Coreelec/sítě a s krabičkou to ani nehnulo, jen mě není jasné proč po reinstalu je tam stejný problém. Není možné že to nějak ovlivňuje router? V kodi už nevím kde bych co změnil Sad
 
Citovat
#9
@mafian: ....router?.... https://www.xbmc-kodi.cz/prispevek-nasta...2#pid91912
 
Citovat
#10
Měl sem podobnej problém na rpi3. Máš tu krabičku připojenou přes wifi, nebo gáblem? Mě to přes wifi ani za prd neslízlo správnej údaj z žádnýho zadanýho, ani defaultního ntp serveru. Když sem připojil káblem, tak to jelo okamžitě jak s defaultem, tak i s různejma zadanejma. Tenkrát sem to zkoušel nějakej čas řešit, různě nastavovat router atd, ale bez výsledku. Nakonec jsem rezignoval a bylo to dobře, protože stejně kabel je kabel :)
 
Citovat
#11
@mafian Jak jsem psal, v části Sítě já NTP nenastavuji. NTP servery bývají defaultně zadané v části Spojení. Co se týče routeru, tak nevím o tom, že by to kdy nějaký explicitně blokoval. To spíše, že nemáš definované DNS servery, ale to by ti pak zase nechodilo nic z Internetu.

Ještě zkus jednu věc, nastavit čas z NTP serveru ručním spuštěním ntpd. Musíš zadat příkaz přes SSH:
Kód:
 ntpd -d -n -q -p pool.ntp.org
Když to zkusíš, okopíruj to, co ti systém po spuštění toho výpisu napíše. Pokud to bude úspěšné, mohlo by to vypadat nějak takto:
Kód:
STREAM:~ # ntpd -d -n -q -p pool.ntp.org
ntpd: 'pool.ntp.org' is 50.205.244.37
ntpd: sending query to 50.205.244.37
ntpd: reply from 50.205.244.37: offset:-0.002072 delay:0.135646 status:0x24 strat:2 refid:0x1cf4cd32 rootdelay:0.000305 reach:0x01
ntpd: sending query to 50.205.244.37
ntpd: reply from 50.205.244.37: offset:-0.002306 delay:0.135590 status:0x24 strat:2 refid:0x1cf4cd32 rootdelay:0.000305 reach:0x03
Tohle ukáže hodně a podle toho, co ti systém vrátí uvidíme, zda principiálně to nastavení funguje. Zjisti si pak, jestli máš v systému správný čas příkazem date. Pak můžeme pátrat dál. No a když to nastavení zafunguje a na nic dalšího nepřijdeme, můžeš zkusit ten příkaz ntpd... vložit do autostart.sh a provizorně ten problém (snad) vyřešit...  1 Víc už asi dohromady nedám.
 
Citovat
#12
@meda: promiň nevím proč, ale tvůj příspěvek se mi nacetl až teď. Zkontroluju router a pak zkusím metodu by jiro snad přijdu na to kde je zakopaný pes. Krabička je na kabelu.
 
Citovat
#13
Ahoj,

minulý měsíc jsem koupil RPi4 a je na něm libreelec s kodi- aktuální verze. A když to připojím přes LAN, tak se čas a datum sesynchronizují.
Jakmile to ale připojím přes wifi, tak to opravdu nefunguje.
Vyzkoušeno ve dvou různých sítích na různých routerech a wifinách.
Na RPI4 se dostanu přes telnet bez problémů. Z RPi4 si pingám na časový server i někam jinam, DNS funguje, ale čas se prostě nezaktualizuje.
Mám tam Thu Apr 11 19:03:08 CEST 2019.

Prošel jsem na netu pár konferencí, zjevně s tím má/mělo problém více lidí, ale řešení jsem nenašel.

Nepřišel na to někdo?

Díííky.

Karel
 
Citovat
#14
@Kaha: Rady od JIRa, pár příspěvků nad tebou, nepomohly?
X96max plus 4/32 + CE 9.2.5 + Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#15
Myslíš k těm NTP serverům? Pokud nastavíš NTP server v nastavení "síť", tak se to propíše do nastavení "spojení".
NTP server tak.cesnet.cz používám na všech zařízeních zcela bez problémů (kamery, routery, ...) . Zkoušel jsem i ntp.nic.cz a výsledek je stejný. Ale hlavně pokud se to připojí na kabel, tak to funguje.

Když napíšu přes SSH:
Kód:
ntpd -d -n -q -p pool.ntp.org

tak vyjede toto:
ntpd: 'pool.ntp.org' is 213.32.40.221
ntpd: sending query to 213.32.40.221
Alarm clock

kdyz napisu: ntpd -d -d -d -n -p pool.ntp.org
tak vyjede toto:
ntpd: 'pool.ntp.org' is 149.28.114.150
ntpd: sending query to 149.28.114.150
ntpd: poll:16s sockets:1 interval:1s
ntpd: timed out waiting for 149.28.114.150, reach 0x00, next query in 2s
ntpd: 'pool.ntp.org' is 194.55.13.132
ntpd: poll:3s sockets:0 interval:1s
ntpd: sending query to 194.55.13.132
ntpd: poll:16s sockets:1 interval:1s
ntpd: timed out waiting for 194.55.13.132, reach 0x00, next query in 1s

Ka
 
Citovat
#16
Zpětná vazba.
Vyměnil jsem starý router za nový a už to funguje.

Ka
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)