• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Nefunkční rádia
#1
Zdar všem,

trápí mě nefunkční rádia. Ať už je to z TVH serveru nebo třeba z doplňku SledováníTV.
Vždy jen vyskočí hláška "Nepodařilo se hrát hru" "Tato hra není kompatibilní s žádným dostupným emulátorem".
Zapnul jsem protokolování, ale moc chytrý z toho nejsem.
Jestli jsem dobře vyčetl, tak místo rádia spouští RetroPlayer.
Nic takového, ale v doplňcích nemám.
Systém je Kodi 19.3 (ale dělalo to i na 19.1 i 19.2) na NvidiaShield.
Přikládám i část log soboru, kde se spouští rádio.


Přiložené soubory
.txt   Nový textový dokument.txt (Velikost: 25,54 KB / Stažení: 4)
S912 Beelink GT1 Ultimate, S905X3 X96 Max Plus, Nvidia Shield, Hisense H55U7A, TVH 4.13
 
Citovat
#2
@lukas.v Je to divný zvyk postnout sem místo odkazu na kompletní log jen nějaký jeho výřez. Jak víš, že to, co by pomohlo najít problém, je právě v té části logu, který jsi vybral?

Jinak Kodi Retroplayer není addon v klasickém slova smyslu, takže ho v doplňcích nenajdeš. Je to součást Kodi s podobným významem jako Kodi Player. Zatímco Kodi Player přehrává mediální obsah, tak Retroplayer slouží k "přehrávání" her.

Co se týče možného zdroje problému, tak pro případné objasnění by bylo dobré vědět, jaký skin používáš (proto je dobré mít ten kompletní log) a také, zda máš v tom skinu definované například vlastní položky menu nebo vlastní widgety a pro jaké zdroje/doplňky. Pokud tedy používáš nějaký jiný skin než výchozí (Estuary), zkus přepnout na ten výchozí a zjisti, zda to dělá i v něm. Pokud ne, tak by to mohlo indikovat jeden z potenciálních problémů právě v tom používaném skinu nebo v jeho nastavení.
 
Citovat
#3
@JiRo: Omlouvám se za log, nějak mě nenapadlo, že by to mohlo takhle být. Příště napravím.

Jinak tedy skin používám AeonNox Silvo, widgety mám taky vytáhnuté i pro Radio.
Mám to takhle už hodně dlouho a vždy to bylo OK. I ze začátku na Kodi 19. Ani přesně nevím, kdy to začalo zlobit.
Zítra tedy zkusím přepnout zpátky na základní skin a uvidíme co to udělá.

Zatím díky
S912 Beelink GT1 Ultimate, S905X3 X96 Max Plus, Nvidia Shield, Hisense H55U7A, TVH 4.13
 
Citovat
#4
@JiRo: Tak jsem to zkoušel a je to teda skinem. Pod základním se rádia normálně spouští.
Přikládám kompletní log od spuštění Kodi.

Tak vyřešeno přehráním skinu z githubu, nyní opět funkční.

kodilog
S912 Beelink GT1 Ultimate, S905X3 X96 Max Plus, Nvidia Shield, Hisense H55U7A, TVH 4.13
 
Citovat
#5
@lukas.v Takže je to to, co jsme předpokládal. Widget s nevhodným zdojem dat. Tohle je problém, který se bohužel hned tak jednoduše nedaří identifikovat. Může být způsobený tím, že se jako zdroj dat použije něco jiného, než to, co definice ve skinu předpokládá. Způsobit to může situaci, že se v Kodi nějak "podělá" cesta ve stromu zadávaných příkazů a zavolá se jiný příkaz než by měl. Mně se něco podobného stávalo při použítí widgetu pro zobrazení sbírky (set) filmu, kdy se jako zdroje dat se použilo zobrazení sbírky SC. Sice se nevolal jiný příkaz, ale způsobovalo to, že se po skončení přehrávání zavolal ten příkaz pro spuštění přehrávání ještě jednou nebo někdy i 2x po sobě. Pomohlo tomu jediné, přestat ten widget používat, případně ho přepsat, aby fungoval jinak.
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)