• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Nenabehne system na Rasp pi 3b
#1
Cauko,
potreboval by som radu. Rozbehal som uz niekolko rasp pi 3 model b. Vzdy system cez noob a instalacia osmc s  doplnkami https://kodi-czsk.github.io/repository/ . Nikdy som s tym nemal problem. Teraz mam jeden co som instaloval znamym, rovnaky postup ako vzdy. Problemom je ze to ide par dni, posledne jeden den a ked. Kodi sa nastartuje, duhova obrazovka, ale ked to ma skocit do prostredia kodi tak to nejde. Raspbery svieti ale obraz nejde. Skusal som mini sd s takymto systemom v inom raspberry a tak isto to nejde. Pomoze format a znovu nahodit system. Dake rady, coho sa mam chytit? Sad

Dakukem
 
Citovat
#2
Otestovat microSD kartu v HD Tune Pro...už jsem jednu ze vzteku rozlomil :)
server: RPi 4B 2GB - RPi OS Lite - Tvheadend 4.2.8
tuners: DVBSky T330, MyGica Mini T230C v2, Pi TV HAT + Telestar DIGIBIT Twin
clients: H96 Pro+ (S912) 3/32GB - CE, X96 mini (S905W) 1/8GB - CE, X96 MAX+ (S905X3) 4/64GB - CE
 
Citovat
#3
Nepoužil jsi náhodou noname kartu nebo naopak hodně novou kartu? Na tvém místě bych zkusil jinou. Napiš typ karty.
RPI zero, 3B, 3B+,4B, 400 (BerryBoot) Ubuntu 18.04, 20.04 Rasbian, LibreELEC 8.x (Krypton), 9.x (Leia), 
 
Citovat
#4
jedna sa o kingstonku 32gigovu class 10, kupovana na slovensku, nie z ciny.

[Obrázek: hlddOL1_d.jpg?maxwidth=640&shape=thumb&fidelity=medium]
 
Citovat
#5
1  kupovana na slovensku, nie z ciny (Made In Taiwan)  1  - nic ve zlém  4
MagicSee N5 MAX S905X3 4/32 → CE 9.x \ RPi3B-RPi4 → L9.x \ HTPC → L9.x \ XOne S  18 \ X96 - S905X 2/16 → CE 9.x \ NAS Synology 212J → DSM 6.x \ Vero 4K+ → OSMC 18
 
Citovat
#6
(20.9.2018, 13:07)Rossi D Napsal(a): 1  kupovana na slovensku, nie z ciny (Made In Taiwan)  1  - nic ve zlém  4

Vyrobena Taiwan :)  Myslel som to tak ze by to nemal byt zidny fake Big Grin
 
Citovat
#7
Jak jsi na počátku napsal zkus ji znovu naformátovat dát tam NOOBS. Pouze bych si stáhl nejnovější verzi z webu a pokud to nepomůže tak bych se tím netrápil a vzal novou kartu.
RPI zero, 3B, 3B+,4B, 400 (BerryBoot) Ubuntu 18.04, 20.04 Rasbian, LibreELEC 8.x (Krypton), 9.x (Leia), 
 
Citovat
#8
(20.9.2018, 21:52)karel.veselsky Napsal(a): Jak jsi na počátku napsal zkus ji znovu naformátovat dát tam NOOBS. Pouze bych si stáhl nejnovější verzi z webu a pokud to nepomůže tak bych se tím netrápil a vzal novou kartu.

Skusal som, je tam najnovsi soft, padlo to uz 3krat... skusim inu kartu ked sa k tomu dostanem, dam vediet :)
 
Citovat
#9
Ještě mě tak napadlo zkusit nainstalovat libreelec nebo openelec s tím tvým doplňkem, zda není problém v OSMC. Dělalo mě to při změně firmware maliny, pravda před pár verzemi OSMC.
RPI zero, 3B, 3B+,4B, 400 (BerryBoot) Ubuntu 18.04, 20.04 Rasbian, LibreELEC 8.x (Krypton), 9.x (Leia), 
 
Citovat
#10
@sobrudolph -Za prvé zbytečně necituj. Za druhé nemáš možnost zapůjit tu kartu, která funguje v tebou instalovaných RPi2/3???
Za třetí... https://www.raspberrypi.org/documentatio...matting.md
... Nepoužívat formátování exFAT. Přeformátovat na FAT32.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#11
takze ako som pokrocil alebo nepokrocil:
-kupil som novu SD kartu a naformatoval ju na fat32, cez software SD Card Formatter, ale toto robim vzdy, rozbehal som niekolko kusov KODI a nikdy som s tym problem nemal
- na novu kartu som nahodil KODI zo zalohy (cista instalacia najnovsi noob - zaloha img suboru, moja vlastna). Skusal som to doma na mojom rasp pi b+ a ficalo to niekolko dni, poslal som tuto novu kartu domov na druhe rasp pi b+ ale zas to islo len do prveho zapnutia. Ak tuto kartu potom skusim vlozit do mojho rasp ktore mam doma, tiez to nenabehne.
- aktualne mam doma obe rasp pi... to s ktorym je problem som skusil napojit na monitor, nahodil novy system, aby som vylucil zasah do kodi z tv (neviem ci tv moze zmenit nastavenia kodi), ale stalo sa to iste. Na monitore to nabehlo na prvy krat (cista instalacia z img suboru) ale ked som to vypol a zapol, uz to nenabehlo.

Zaver:
Problemom je samotne rasp pi, ktore pravdepodobne urobi nieco so softwarom. Neviem urcit ci samotne kodi nabehne alebo nie, ked nedostavam obraz cez hdmi kabel...

Viete nejako poradit?

Dakujem
 
Citovat
#12
Takze, skusal som vymenit HDMI kabel - nepomohlo, skusal som vymenit SD kartu - nepomohlo. Skusal som davat starsiu verziu OSMC - nepomohlo, skusil som iny kus raspberry pi - nepomohlo.

Zaver je taky, ze to robi televizor - Sony Bravia KDL-32R500C , lebo monitore to fici, na dalsich dvoch televizoroch tak isto. Toto Sony urobi to, ze novom nahodeni systemu sa to na nej zapne, funguje to, ale ked sa to uz vypne, tak to nenabehne. Nasledne to nenabehne ani na inych TV, karta SD sa musi naformatovat a nanovo nainstalovat.

Ma niekto daky napad? Vie pomoct s problemom?

DAKUJEM
 
Citovat
#13
Samotný televizor nemůže ovlivnit nastavení Kodi. Vyzkoušel bych čistou instalaci LibreELEC a pro začátek bez dalších doplňků.
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#14
Sony Bravia KDL-32R500C 1366 x 768. Komunikace mezi zdrojem a TV po HDMI vyjedná rozlišení a frekvenci, TV systém. Možná se NOOBS/OSMC nastaví na něco, kde další vyjednávání není možné.
Kodi běží vždy na nějakém systému: LibreELEC, OpenELEC, OSMC. Multiloadry NOOBS a BerryBoot.
Vyzkoušej prostě kvůli té SONY TV jiný systém pro RPi, jak radí @Petrvald.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#15
@sobrudolph Někdy metoda pokus omyl nevede k cíli, respektive trvá zatraceně dlouho. Především postrádám tvoji jasnou formulaci. Co to znamená, "že to už nenaběhne". Tzn.
  1. nespustí se systém
  2. systém spustí ale nespustí se Kodi
  3. spustí se Kodi ale nic se na obrazovce nezobrazí
Dále je důležité vědět, co to znamená, "když se systém vypne":
  1. vypínáš napájení RPi
  2. RPi vypneš přes menu Kodi nebo tlačítkem na DO
To jsou zásadní informace, bez nich jsou každé další pokusy jen střelbou naslepo.
 
Citovat
#16
@sobrudolph .....Vyzkoušel bych v TV vypnout BRAVIA Sync v menu, komunikuje přes HDMI. Str. 26 CZ.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#17
@sobrudolph...Podíval jsem se na stránky SONY a zkusil bych použít to druhé HDMI na televizi protože jedno je označené HDMI (DVI) a druhé HDMI (ARC) takže předpoklad je, že se v něčem budou lišit. Nevím v kterém to máš nyní tak pokus-omyl dej to do druhého.
RPI zero, 3B, 3B+,4B, 400 (BerryBoot) Ubuntu 18.04, 20.04 Rasbian, LibreELEC 8.x (Krypton), 9.x (Leia), 
 
Citovat
#18
Dakujem za vsetky rady, toto problemove kodi je u rodicov, takze ked sa tam dostanem, doplnim zas prispevok a odpovede na vsetky otazky co ste sa pytali :)
 
Citovat
#19
Aktualna situacia:
Dneska som to zas hodil na tu SONY telku, zapne sa mi klasicky raspberry pi, nabehne ta duhova obrazovka, nabehne logo raspberry pi s moznostou stlacit shift a tam to skape. Proste to dalej nejde, len cierna obrazovka.

Na prvykrat to ide vzdy (ked je prvykrat nahodeny system). Po vypnuti a zapnuti to ide, ale ked to vypnem a zapnem za cca 10minut, tak to skape a len cierna obrazovka. Ked dam potom pri spustani shift a pozriem sa do config.txt tak je prazdny. Nahadzal som tam nasledovne prikazy:

disable_overscan=1
sdtv_mode=2
start_x=1
sdtv_aspect=1
hdmi_ignore_cec_init=1

Tieto prikazy som nasiel na jednom fore ze co maju ludia v config.txt, po restarte to nabehne a ide to. Ked to restartnem, kde to. Ked to zapnem/vypnem ide to. Ked to vypnem a necham tak dlhsiu dobu /10minut/, tak to zas skape, nabehne len cierna obrazovka. Ked sa dostanem cez shift do systemu, opat je config.txt prazdny.

Skusal som urobit novy prihlasovaci profil v systeme, niekde som sa docital, ze to pomaha, ale bez zmeny. Skusal som druhe hdmi vstupne na telke ale bez zmeny. Skusal som dat napajanie do ineho USB v telke a bez zmeny. Skusal som napajanie cez elektriku, ale ked to vypnem a zapnem po dakych 10minutach, zas to nejde. Funkciu Bravia Sync na TV mam vypnutu.

Ak to hodim na druhu telku, nema to absolutne ziadny problem. Ak to skusim nahodit na druhu telku po tom ako to skape na tejto Sony TV, tak ani na tej druhej telke to nejde, az ked opat nastavim config.txt. Skusal som hodit kartu do druheho raspberry pi a ide to tam bez problemov. Problem je jedine tato Sony TV.
Ked to skusam na inej telke, pouzivam ten isty hdmi kabel na prepojenie, to iste napajanie, ten isty sietovy kabel...
Som uz v koncoch....

este dake napady?

Myslim ze si na to musim najst viac casu a skusit tam nahodit iny system ci to pomoze...

@JiRo
1.nespustí se systém
-nabehne ta duhova obrazovka, nabehne logo raspberry pi, kde je moznost stlacit shift a potom uz len cierna obrazovka, telka vypise, ze nema zdroj obrazu
2.systém spustí ale nespustí se Kodi
- popis v 1. bode
3.spustí se Kodi ale nic se na obrazovce nezobrazí
- spatne som to definoval, spusti sa raspberry pi ale kodi nenabehne, popisal som to v bode 1.
Dále je důležité vědět, co to znamená, "když se systém vypne":
1.vypínáš napájení RPi
- vypinam napajanie, teda vytiahnem raspberry pi z usb kabla, ktory ide do telky
2.RPi vypneš přes menu Kodi nebo tlačítkem na DO
- ano skusal som vypnut aj cez menu v kodi, ale je to stale to iste, ak to ostane dlhsi cas vypnute, premaze sa config.txt a po uvodnom nabiehani ako som pisal vyssie v bode jedna nastane len cierna obrazovka
 
Citovat
#20
https://www.raspberrypi.org/documentatio...t/video.md
https://youtu.be/OF-dfJEvYrY
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)