• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Pi 3 B+ Ethernet problem
#1
Hezký den všem,
upgradoval jsem malinu na nejnovější model 3B+ 
a mám problem s ethernetem. 
Jak v LibereElec tak v Mihaus verzi.
Problém spočívá v tom,  že pokud to pustím na 1000 Mb/s tak se to kouše. 
Pokud jedu na 100 je to OK. Abych vyloučil chybu HW tak mám už druhý kus, který se chová obdobně.
Pokud jedu na WiFI - vše je OK.
Zkoušel jsem i OS Rasbian - a tam to na gigabit taky jelo dobře.

Má někdo podobné zkušenosti? 

marmen
 
Citovat
#2
RPi 3B+ má sice Gigabit ethernet, ale je připojen přes USB 2.0, takže v reálu je rychlost kolem 200 Mb/s. Včera mi přišel nový switch a můžu potvrdit přenosovou rychlost cca 20 MB/s (LibreELEC 8.2.5). Na disku nemám snad video, které by překročilo datový tok 40 Mb/s, nechápu co tam pouštíš že si stěžuješ na nestabilitu ?
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#3
@marmen, @Petrvald -Já teď zatím testuju novější RPi 3 a Zero jen přes WiFi a tam jsem překvapený funkčností.
K použití LAN na RPi 3B+ jsem nepřikročil. Proto se hloupě zeptám, jak nastavuješ nebo omezuješ rychlost 10, 100 nebo 1000? Díky za podrobnosti.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#4
Když RPi připojím do portu gigabit. switche - tak když pustim něco většího  z doplňku stream-cinema - tak se to do minuty kousne.Když to prosím přes port 100-kového switche vše je OK a přes WiFi taky vše OK. Zkoušel jsme i OSMC a chovalo se to stějně. Také zkoušeny dva typy gigabit.switchů - opět stejný výsledek a tak jsem si myslel že je to chybný HW tak mi to vyměnily za jiný kus a také stejný výsledek.
 
Citovat
#5
@meda: některé routery umožňují nastavit natvrdo 10/100/1000 a to samostatně pro jednotlivé LAN. Možná to nastavoval tam.
X96max plus 4/32 + CE 9.2.5 + Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#6
Ano, měl jsem (s názvem QoS) nastavení jednotlivých portů LAN ve starém routeru. Teď nevím (nebo v novém nemám).
Otázku jsem postavil tak, abych nepodsouval směr odpovědi, vždy se pak dozvím méně.
Já mám po odvalení gigabitového switche teď jen 100, tak zatím nevyzkouším. Ale popis jednoduchého testování od @marmen vzbuzuje obavu, že je v RPi3B+ něco nedotaženého v propojení LAN/USB2 (používá nějaké kešování?). Respektive LE problém na Gbit má, Raspbian nemá.
Třeba někdo z vás vnese světlo dalším zkoušením
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#7
@marmen: zatím jsi nám toho moc neřek...
Co nějaké parametry u problémového videa (rozlišení, bitrate, kódování..) ?
Chceš říct, že naprosto stejné video spuštěné přes WiFi přehraješ bez problémů ?
Zkoušel jsi test rychlosti ethernet připojení ?
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#8
@Petrvald: Jsem jen trochu poučený laik. Tak že parametry videa nevím jak zjistit.
Nicméně testuji to na doplňku strem cinena - koncerty-David Gilmour - Live in Pompei 2017 tak to testuji na tom 1080 - co má 10 GB
Test ethernet připojení nevím jak udělat. Prosím případně o návod.
 
Citovat
#9
@marmen: jestli si dobře pamatuji, tak SC má test přímo v sobě (Nastavení->Speedtest).

@meda: sorry, v žádném případě jsem nechtěl podceňovat tvou znalost věci.
X96max plus 4/32 + CE 9.2.5 + Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#10
@jkmh -nic se neděje, i kdybys podceňoval, budeš stále na správné stopě. Přiznávám, že chci spíš být uživatelem než vývojářem, pokud nedocházím rychle k cíli. A to většinou nedocházím, neb jsem líný a nechápavý. Jj, s věkem je to stále víc pravda. [Obrázek: thumbsup.png]
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#11
@marmen
Doplněk na test rychlosti ke stažení zde: Arnu Box Speed Tester - tester rychlosti připojení k internetu

Pro zjištění podrobných informací o videu odešli příkaz přes SSH (Putty, mobilní aplikace ...):
Kód:
kodi-send --action=PlayerDebug
nebo připoj klávesnici a použij zkratku Ctrl+Shift+O

Screenshot vytvoříš kombinací Ctrl+S
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#12
Tak jsem se konečně dostal k testu rychlosti. Nevidím rozdíl v 1000 a 100.


Přiložené soubory Miniatury
       
 
Citovat
#13
Test je naprosto v pořádku, maximální bitrate které si můžeš dovolit je cca 25 - 30 Mbps a to za předpokladu že ti nebude ubírat data jiné zařízení. Rozdíl mezi rychlostí 100 Mbps a "gigabitem" poznáš v případě, že budeš kopírovat soubory přímo z PC do RPi .

Nedávno jsem zkoušel přehrát videa přes Sambu na RPi 3B+, datový tok se pohyboval i nad 70 Mbps. Přehrávání naprosto plynulé (LibreELEC 8.2.5):
   
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#14
@ Petrvald
Souhlas.
Dnes to ještě testnu na tom samém stremu, kde se to kouše.Nechá se to nějak smysluplně zalogovat?
 
Citovat
#15
Během přehrávání aktivuj ladící informace (Ctrl+Shift+O) a vytvoř screenshot. Z něj pak můžem vyčíst, jestli náhodou nepřehráváš něco s čím si malina neporadí. Doplněk SC nepoužívám, ale třeba se najde někdo, kdo bude ochoten otestovat problémové video na RPi 3B+.
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#16
Nevím co se přesně stalo , ale nahral jsem updat z https://forum.kodi.tv/showthread.php?tid=298461 a vše jede dobře. Děkuji za podporu.
 
Citovat
#17
Na LibreELEC 9 mi to též běhá celkem dobře, jen není zaručena 100% funkčnost, pořád je ve fázi ladění.

Ještě doplním pár nastavení , které provádím po instalaci systému. Není to nic zásadního, ale odlehčí se tak pár procesů běžících na pozadí.

1. zakážu automatické aktualizace OS (manual)
2. deaktivuji bezdrátové sítě
3. zakážu automatické aktualizace doplňků
4. zakážu protokolování událostí
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#18
Možná to taky trochu souvisí, mám podobný problém.
RPi 3B+, při přehrávání uloženého videa (NAS, flash) vše funguje jak má klidně celý den. Při přehrávání z TV archivu (Nova, Prima....) dojde k zatuhnutí a po chvilce přehrávání spadne download mám 60-90 Mb. Při přehrávání bez kodi (ntb, PC) vše funguje bez problému. Jedu na GB lan, WiFi n i ac totéž, pokusím se ještě vyhrabat  100Mb switch
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)