• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Problem s Kodi 20
#1
Zdravim. Aktualizoval som na Kodi 20, skin mam Arctic Zephyr Realoded, SCC. Po kazdom spusteni filmu mi Kodi padne, vypne sa. Nevie mi niekto poradit, alebo nemal podobny problem, ktory vyriesil? Dakujem za info.
 
Citovat
#2
@janci.p: Dělá ti to jen s SCC nebo i s jiným videodoplňkem? Zkus origo skin (Estuary), jestli to nepomůže. Tady https://discord.com/channels/70660272656...9942191134 se to probírá, ale bez výsledku.
X96max plus 4/32 + CE 20 final + skin - upravený Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19.2 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#3
@janci.p Na mě to působí tak, že jsou V SCC nějaké skryté bugy, které se projeví v okamžiku, když se do nějakého místa ve stromu položek v menu SCC vstoupí napřímo. Což se stává např. v okamžiku, pokud máš ten vstupní bod použitý ve widgetu nabo si ho uložíš do node.

Kodi se svou rekurzí volání addon nabízí poměrně zajímavé možnosti, ale pokud se v addon v této oblasti vyskytne nějaký problém, chyba nebo nějaké hodně "tvořivé" řešení (tvořivé rozuměj netradiční, jdoucí více či méně mimo pravidla a zásady Kodi), může to pak být problém. Komplikací v tomto případě je, že pokud se do daného místa, které je například obsahem widgetu, dostane uživatel běžnou cestou v rámci pohybu po stromu položek v menu SCC, tak to funguje dobře, ale pokud ho zavolá prímo (ve widgetu, node) tak to buď nefunguje vůbec, nebo to má neblahé důsledky. A tohle skiny, používající různé "helper-y" pro možnost definice uživatelsky zadaných widgetů, dělají. A Arctic Zephyr Realoded k nim patří také.

Rada @jkmh: je správná a mělo by se tak postupovat vždy. Zkus výchozí (a nijak neupravený, a tím myslím i bez případného použití uživatelsky definovaných nodes, obsahujících položky typu "folder") skin. Pokud tam ten problém bude přetrvávat, tak je ta příčína jinde. Víc asi neporadím, já takové porblémy u svých instalací nepozoruji. O položkách v menu SCC, kde jsou tyto problémy vím a prostě je při svých voláních widgetů nebo nodes nepoužívám (např Search, Trakt, ...).

A mimochodem, problémy podobné těm tvým se diskutují i na jiných fórech (discord SCC). Ale to vlastně @jkmh: napsla už taky... 6
 
Citovat
#4
Dakujem za info, budem to sledovat na Discorde. Skusal som prepnut na zakladny skin, par filmov spustilo, ale potom rovnako padal.
 
Citovat
#5
@janci.p Tak to je důležitá informace, která tu mou analýzy a možné příčíny staví do jiného světla. Problém bude tedy asi jinde. Ale ano, nejlepší informace získáš na discordu, tam jsi přímo u zdroje.
 
Citovat
#6
@janci.p: Mám totožný problém. Já používám výhradně Estuary a začalo mi to padat až po instalaci Nexus 20. Dříve se to nikdy nestalo. Používám jen SCC - najdu film, spustím a padne to. Spustím Kodi, najdu tentýž film a tentýž stream, spustím to a jede bez problémů. Na Discordu jsem účet zrušil, přišlo mi to chaotické fórum, na rozdíl od tohohle. Kdyby se ti podařilo něco zjistit, můžu požádat o zpětnou vazbu? Moc díky.
Našel jsem tu 3 roky starou podobou diskusi, ale to bylo na Windows. Já mám Kodi na Tesle XT550, kde je Android 9.0.
 
Citovat
#7
Presne ten istý problém na Android 9.0 mám aj ja
WIN 10; KODI 20; TV LG 55UH661v webOS 3.0; 
Ugoos AM 6, Android 9.0; KODI 20, UPC 250 Mb
 
Citovat
#8
(22.1.2023, 14:26)chimo Napsal(a): Používám jen SCC - najdu film, spustím a padne to. Spustím Kodi, najdu tentýž film a tentýž stream, spustím to a jede bez problémů.
Jak tomu mám rozumět? Tak, že v Kodi, které před tím již nějakou dobu běželo, pustíš film, a Kodi spadne. Pak to samé Kodi spustíš znova a okamžitě po jeho startu pustíš ten samý film a běží to?

Podstatné asi budou v této chvíli 3 věci.
  1. Android a HW na kterém běží, což je vždycky v Kodi trochu problém (tedy větší než s jinými typy instalací)
  2. Co se dělo před prvním spuštěním filmu, protože některé akce mohou mít "kumulativní" charakter - tzn. že prostředí Kodi mohou nějak ovlivnit a další spuštění filmu už Kodi nepřežije. Pokud spuštíš film hned po dalším spuštění Kodi, je Kodi v iniciálním stavu a tak to projde. Tohle si musíš ale vystopovat sám...
  3. Log - hádat co se asi mohlo stát se fakt z těch pár informací, nedá. Otázkou je, jestli bude někdo natolik fundovaný, že ti poradí. Zkusit to ale můžeme...
Takhle na blind se fakt těžko odhaduje, ale jedna z možných a častých příčin může být problém s pamětí. Delší běh Kodi před prvním spuštěním filmu může ukrojit více paměti než je k dispozici krátce po dalším spuštění Kodi a následném spuštění téhož filmu. Možná máš příliš velkou video cache a pomohlo by, kdybys ji snížil, ...
 
Citovat
#9
@JiRo: ano, rozuměl jsi popisu dobře. Popsal bych více, ale tím, jak to spadne, tak se neobjeví žádná hláška, ani nic v logu.
Ad1) to nedokážu úplně posoudit, jsem v tomhle amatér, ale Kodi doposud běželo bez problémů, tak myslím, že v té krabici problém nebude
Ad2) co se dělo předtím člověk až tak nevnímá, takže si budu psát poznámky, ale dneska jsem dopolko koukal na tenis na O2 TV puštěnou v Kodi
Ad3) v logu bohužel nice není, protože to nedá žádnou chybovou hlášku, prostě se vypne

Možná s tou pamětí jsi to trefil. Mám tam open wizard, tak zkusím něco promazat, to mě nenapadlo. Budu teď sledovat, co se stane, když nechám Kodi puštěné dlouho a hlavně tu O2 TV, to by mohl být dobrý tip, protože netuším kolik to z paměti bere, takže když se přepnu hned na film, tak to třeba bude tím.
Moc díky za reakci. Jak chybí info v logu, je to na nic. Podobná blbost, jak když mi HDMI začal přepínat frekvence a nikdo neví proč :-).
 
Citovat
#10
@JiRo: tak jsem vyčistil paměť, v cache bylo 10 MB, ale v thumbnails přes 1GB. Včera večer to vypadalo ok. Dnes puštěno Kodi, spuštěn film a po 20 min to celé spadlo. Spuštěno znova a v pohodě to dojelo. Spouštím další film a opět to spadlo.
Dávám odkaz na log. Pořád mi to hlásilo, že je to moc velké (přes 1MB) a nešlo to uploadovat, ale nakonec se to nějak podařilo. Vypadá to, že některé addony se neaktualizují. Dále jsem zjistil, že se nelze přihlásit do repozitářů xbmc-kodi CZ/SK a kodi CZ&SK doplňky. Některé errory hlásí, že za to můžou staré definice schémat, takže nesjou nachystané na Nexus?
V open wizardu jsem měl chybu, která měla souvislost s pythonem, ale bohuel jsem neuložil a po výměně HDMI kabelu už tam ta hláška není. Divné. Bylo tam právě něco o video cache
Když to dnes zase tak blblo, tak jsem vyměnil HDMI kabel. Zapnul Kodi, spustil 4 filmy a vše nabíhalo ok. Pak jsem spustil O2 TV, vypnul, spustil na SCC film a hned to padlo. Nikde žádná chyba jako předtím. Tak uvidím, jestli se zase časem objeví něco v tom wizardu. 

LOG
 
Citovat
#11
@jkmh: Můžu tě poprosit o pomoc, co tahle hláška znamená? Zřejmě mi kvůli tomu padá Kodi, když spustím film na SCC. Doufám, že odkazy budou fungovat. Obrázek jde sem vložit dost blbě, aspoň pro mě :-). Děkuji

Log foto
 
Citovat
#12
@chimo: Ta hláška odkazuje na citované řádky ze souboru stream_cinema_player.py. A znamená, že SCC chce něco co neexistuje nebo to existuje, ale ve tvaru, který nezná. V tomto případě to zřejmě souvisí se zvukovou stopou nebo s titulky. Otázkou je, jestli ti to dělá u jakéhokoliv streamu nebo jen u konkrétního.
To, že kvůli tomu ti padá Kodi je jen tvoje domněnka. Můžeš mít pravdu, ale nemusíš. Lepší by bylo, abys přímo z nastavení SCC uložil celý log a sem opsal link, který se ti vygeneruje.

Nejsem programátor, takže se předem omlouvám všem znalým, pokud to mé vysvětlení pokulhává.
X96max plus 4/32 + CE 20 final + skin - upravený Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19.2 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#13
Edit: to jsem napsal blbost níže, SCC je z jiného repozitáře.
@jkmh: používám jen SCC na filmy. Právě, že nevím, co přesně hledat, takže máš pravdu, že domněnka nemusí být správná. Zkusím mrknout na ten log v nastavení SCC. Log z Kodi, viz. link, jsem zkouknul a maximálně tam pochopím, že některé add-ons mají potíž, protože mají staré schéma - asi nejsou upravené na Nexus 20. Jsou tam třeba repository.kodi-czsk nebo repository.xbmc-kodi.cz a to právě nevím, jestli má vliv, protože SCC využívá nějaké závislosti a když jsem do nich koukal, tak jsou všechny aktuální. Musím ještě zapátrat.
LOG KODI
 
Citovat
#14
@chimo: To je stejný log. Jen se k němu dostaneš rychleji a rychleji odešleš. Teď mi došlo, že nepotřebuješ "normální" log, ale crash log.
Ještě dotaz - Kodi spadne = kousne se nebo samovolně restartuje. Ten samovolný restart není hned, chvíli to trvá, jakoby se Kodi rozmýšlí jestli restartovat nebo ne.
Ten najdeš, stejně jako ostatní v Androidu logy, podle této tabulky
Log file - Official Kodi Wiki. Pro tebe bude nejspíš platit umístění:

 /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/temp/kodi.log
X96max plus 4/32 + CE 20 final + skin - upravený Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19.2 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#15
@jkmh: Kodi se úplně vypne a objeví se mi hlavní obrazovka na Androidu. To mě nenapadlo, že by to mohl být restart, takže jsem nečekal a spustil Kodi hned.
Mrknu na ten crash log.
Došlo mi, že nemám aktualizovaný repozitář xbmc, myslel jsem, že se to aktualizuje automaticky, ale musím to pustit ze zipu. Jsem v tomhle amatér, tak se omlouvám za blbý dotaz, ale myslím si správně, že se to repo komplet přepíše tím zipem na Nexus verzi a nemusím nějak řešit mazání nebo tak něco toho původního xbmc-koid.cz určeného pro Matrix? Je to prostě aktualizace skrze správný zip. A mám log viewer a uploader, tak jsem myslel, že si do té cesty sahá napřímo, takže na té cestě storage/emulated....najdu to samé, co jsem sem dal nebo ne?
 
Citovat
#16
@chimo: Restartem Kodi myslím skutečně restart Kodi = naběhne až do Kodi. XBMC-kodi repozitář si klidně zaktualizuj ze zipu, starý se přepíše novým. Jinak si vynuť z contextmenu u každého repa aktualizaci. A určitě bych zrušil repository.kodi-czsk. To je staré, určitě neudržované a podle mě na Kodi20 už nevhodné. Píšeš, že používáš jen základní skin a SCC. Pak odinstaluj vše mimo Kodi repa, to ani nepůjde,repository.xbmc-kodi.cz  a repository.hacky. A až to bude fungovat, pak přidávej další.
X96max plus 4/32 + CE 20 final + skin - upravený Confluence / TV Samsung QE55Q6FNA
AVR Denon 1600H / Dali Spektor 5.1
Win10pro + Kodi19.2 Matrix
NAS Synology 215j 3TB Raid1
Router Turris 1.1
 
Citovat
#17
@jkmh: jestli to zase spadne, tak počkám déle, jestli to udělá restart. Repa znova projdu, něco jsem už aktualizoval, tak mrknu, jestli to mám vše. Kodi-czsk jsem si říkal, že tam je zbytečné, takže díky za tip. Instaloval jsem to hned na počátku, ale koukám, že to stejně nemá takovou podporu jako zde. V Kodi mám jen SCC, O2 tv a Skylink a nic jiného tam nepoužívám. Moje Hisenska nemá na O2 apku, takže jsem kvůli tomu před rokem a půl koupil Teslu s Androidem a tam bylo Kodi TV Center a takhle jsem to objevil :-). Nechám tam ten základ, jak píšeš a uvidím, co se bude dít. Moc díky za konzultaci.
 
Citovat
#18
@jkmh: info, jak jsem dopadl - xbmc-kodi repo aktualizováno na Nexus, to druhé jsem dal pryč. Restartoval Kodi a několikrát jsem se přepnul mezi O2, skylinkem a SCC (pokaždé jsem vybral jiný film) a vše vždy naběhlo a Kodi nespadlo. Tak snad to nebyla ojedinělá vlaštovka. Otestuju ještě na večerním provoze, zatím ok.
 
Citovat
#19
Zdravim všechny,to že kodi nexus padá při přehrávání streamu je fakt,dělá to mě i kolegovi z práce...na nexus rc2 to nedělalo.
Ještě mám problém a dotaz na instalaci ze zip,
na flashce žádný zip vidět není i když tam jsou.
U matrixu vše v pořádku. Máme tv philips...
 
Citovat
#20
@frank68: v nastavení aplikací klikni na kodi - oprávnění - povolit vše a měli by se ti všechny soubory znovu objevit...
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)