• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Vítejte návštevníku! Přihlášení Registrace


Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
Zmizel obraz z TV - chyba HDMI?
#1
Zdravím.
Po výpadku proudu v celé čtvrti mi přestal TV Samsung zobrazovat signál z RPI 3. Vyzkoušel jsem vš echny HDMI vstupy v TV, vyzkoušel jsem několik HDMI kabelů - pořád stejný výsledek.  Vyzkoušel jsem i jiné RPI, které vlastním a zaké se nic nezobrazilo. 
Pokud ovšem k této TV připojím NB přes HDMI - vše funguje a obraz se ukáže.
Pokud RPI připojím k jiné TV tak také funguje - tímpádem by mělo být vpořádku.

Má někdo nápad, kde by mohl být zakopaný pes?
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#2
Tvé popisy funkcí a NEfunkcí nemají logický průnik. Buď někde děláš chybu, nebo nezkoušíš se stejnými podmínkami.
Vyzkoušej z NB stejné zobrazení, jako dává RPi 3, 1920x1080-60p. Nebo z NB vyzkoušej všechna rozlišení.
Vyzkoušej vypnout TV a pak ještě odpojit od zásuvky na 5 minut. (Mně se takhle podařilo obnovit zbloudilou funkci CEC.)
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#3
A zkoušel jsi taky jiný kabel?
 
Citovat
#4
Není třeba RPi zapojené do jiného vstupu HDMI než je zobrazeno v TV ?  Například RPi zapojené do HDMI 1, ale TV zobrazuje HDMI 2, tudíž žádný signál..

Zkus ještě zapsat parametr do config.txt, který vynutí posílání dat přes HDMI:
Kód:
hdmi_force_hotplug=1
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#5
(13.4.2018, 12:01)astv Napsal(a): A zkoušel jsi taky jiný kabel?

zkoušel - píšu v dotazu

(13.4.2018, 12:16)Petrvald Napsal(a): Není třeba RPi zapojené do jiného vstupu HDMI než je zobrazeno v TV ?  Například RPi zapojené do HDMI 1, ale TV zobrazuje HDMI 2, tudíž žádný signál..

Zkus  ještě zapsat parametr do config.txt, který vynutí posílání dat přes HDMI:
Kód:
hdmi_force_hotplug=1
zkoušel jsem přepínat všechny vstupy, zkoušel jsem přepojovat do všech vstupů kabel... nic
parametry zapisovat neumím

(13.4.2018, 8:11)meda Napsal(a): Tvé popisy funkcí a NEfunkcí nemají logický průnik. Buď někde děláš chybu, nebo nezkoušíš se stejnými podmínkami.
Vyzkoušej z NB stejné zobrazení, jako dává RPi 3, 1920x1080-60p. Nebo z NB vyzkoušej všechna rozlišení.
Vyzkoušej vypnout TV a pak ještě odpojit od zásuvky na 5 minut. (Mně se takhle podařilo obnovit zbloudilou funkci CEC.)

No ještě jednou k NEfunkcím... Jednou z 20 pokusů různých zapojení se obraz z rpi objevil, ale po cca 30 minutách se vše opět vrátilo do stavu "nezobrazuji". 
V NB jsem vyzkoušel všechna nabízená rozlišení - vše se v TV zobrazovalo - nebyl jediný problém...
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#6
Vyjmi kartu z RPi a vlož do PC, pak najdi soubor config.txt a do něj přidej onen parametr (na samostatny řadek).
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#7
(13.4.2018, 18:39)Petrvald Napsal(a): Vyjmi kartu z RPi a vlož do PC, pak najdi soubor config.txt a do něj přidej onen parametr (na samostatny řadek).

Bohužel, nepomohlo to...
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#8
Poslední co mě napadá je vyzkoušet parametr pro zvýšení intenzity signálu HDMI:
Kód:
config_hdmi_boost=9

Defaultní je hodnota 5 maximálně můžeš nastavit 11. Vyšší hodnoty se používají, pokud je HDMI kabel příliš dlouhý nebo spojení nestabilní.
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#9
(15.4.2018, 9:42)Petrvald Napsal(a): Poslední co mě napadá je vyzkoušet parametr pro zvýšení intenzity signálu HDMI:
Kód:
config_hdmi_boost=9

Defaultní je hodnota 5 maximálně můžeš nastavit 11. Vyšší hodnoty se používají, pokud je HDMI kabel příliš dlouhý nebo spojení nestabilní.

je jedno do kterého místa kódu to napíšu?
např? (mám tam přidávat křížek jak je u ostatních řádků)


# overscan_right=59
# overscan_top=20
# overscan_bottom=20
# hdmi_force_hotplug=9

díky
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#10
Mno už jsem to zde psal, stačí pohledat: RPiconfig - config.txt (možnosti editace) nebo podrobněji na eLinux.org RPiconfig
# - komentář deaktivuje celý řádek, parametr je nefunkční !
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#11
(15.4.2018, 10:41)Petrvald Napsal(a): Mno už jsem to zde psal, stačí pohledat: RPiconfig - config.txt (možnosti editace) nebo podrobněji na eLinux.org RPiconfig
# - komentář deaktivuje celí řádek, parametr je nefunkční !

Tak po chvíli studia jsem to zapsal do configu. Bohužel nepomohlo..
díky
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#12
Pokud se vrátíme k prvnímu příspěvku a větám:
Vyzkoušel jsem i jiné RPI, které vlastním a zaké se nic nezobrazilo.
Pokud ovšem k této TV připojím NB přes HDMI - vše funguje a obraz se ukáže.
Pokud RPI připojím k jiné TV tak také funguje - tímpádem by mělo být vpořádku.

...potom ještě nevíme, jestli do toho jiného RPi jsi vložil stejnou SD kartu se systémem, nebo má svou.
I s nějakým jiným systémem bys měl aspoň vidět start RPI s "oranžovou duhovou" obrazovkou.
Třeba si opravdu ta dvě zařízení společně nerozumí s tím HDMI kabelem, co máš. Zkus pořídit HDMI 1.4 (někdy označený jako High Speed, podpora ethernet a 3D) a nejlépe 50cm.
Další nápady už nemám...... Snad jen zkusit LibreElec 8.2.x
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#13
(15.4.2018, 12:36)meda Napsal(a): Pokud se vrátíme k prvnímu příspěvku a větám:
Vyzkoušel jsem i jiné RPI, které vlastním a zaké se nic nezobrazilo.
Pokud ovšem k této TV připojím NB přes HDMI - vše funguje a obraz se ukáže.
Pokud RPI připojím k jiné TV tak také funguje - tímpádem by mělo být vpořádku.

...potom ještě nevíme, jestli do toho jiného RPi jsi vložil stejnou SD kartu se systémem, nebo má svou.
I s nějakým jiným systémem bys měl aspoň vidět start RPI s "oranžovou duhovou" obrazovkou.
Třeba si opravdu ta dvě zařízení společně nerozumí s tím HDMI kabelem, co máš. Zkus pořídit HDMI 1.4 (někdy označený jako High Speed, podpora ethernet a 3D) a nejlépe 50cm.
Další nápady už nemám...... Snad jen zkusit LibreElec 8.2.x

mám 2 ks RPI s prakticky stejnou instalací - zkoušel jsem vše - měnit karty, měnit kabely. U jedné TV jede vše vpořádku - u té druhé prostě RPI nejsou vidět - TV hlásí "bez signálu"
není vidět ani start systému.
Zkusím tedy kabel, který popisuješ, popřípadě jinou instalaci - tedy LibreElec.
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#14
Možná jsem to zde nenašel, ale vše co víme o Tvé TV je to že se jedná o Samsung - nějaké modelové číslo by bylo ? Pokud to zde bylo řečeno, omlouvám se ....
MagicSee N5 MAX S905X3 4/32 → CE 9.x \ RPi3B-RPi4 → L9.x \ HTPC → L9.x \ XOne S  18 \ X96 - S905X 2/16 → CE 9.x \ NAS Synology 212J → DSM 6.x \ Vero 4K+ → OSMC 18
 
Citovat
#15
(15.4.2018, 14:55)Rossi D Napsal(a): Možná jsem to zde nenašel, ale vše co víme o Tvé TV je to že se jedná o Samsung - nějaké modelové číslo by bylo ? Pokud to zde bylo řečeno, omlouvám se ....

Samsung LE32A436T1D
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#16
Asi bude TV tak 10 roků stará ...stát se může leccos. Ještě poslední nápad, zjistit, jaký je rozdíl v připojených signálech z NB proti RPi 3. Jestli ten výpadek elektřiny něco v TV provedl, třeba v NB HDMI nějaký signál není, který u RPi vadí.
Není u TV nějaké nastavení v menu týkající se HDMI?
V nastavení TV HDMI je podle manuálu nějaký Black Level Normal/Low. Atd...atd.
http://downloadcenter.samsung.com/conten...1523864051
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#17
(16.4.2018, 9:45)meda Napsal(a): Asi bude TV tak 10 roků stará ...stát se může leccos. Ještě poslední nápad, zjistit, jaký je rozdíl v připojených signálech z NB proti RPi 3. Jestli ten výpadek elektřiny něco v TV provedl, třeba v NB HDMI nějaký signál není, který u RPi vadí.
Není u TV nějaké nastavení v menu týkající se HDMI?
V nastavení TV HDMI je podle manuálu nějaký Bleck Level Normal/Low. Atd...atd.
http://downloadcenter.samsung.com/conten...1523864051

Bohužel nic nastavit u HDMI nelze...
Trochu jsem googlil a zjistil jsem, že TV Samsung mají obecně často problémy s HDMI vstupem. Žádné z řešení problémů mi ale nepomohlo. Problémy údajně bývaly s připojením PS3 - výrobce pak doporučoval použít komponentní vstup...

(15.4.2018, 13:10)dcart Napsal(a):
(15.4.2018, 12:36)meda Napsal(a): Pokud se vrátíme k prvnímu příspěvku a větám:
Vyzkoušel jsem i jiné RPI, které vlastním a zaké se nic nezobrazilo.
Pokud ovšem k této TV připojím NB přes HDMI - vše funguje a obraz se ukáže.
Pokud RPI připojím k jiné TV tak také funguje - tímpádem by mělo být vpořádku.

...potom ještě nevíme, jestli do toho jiného RPi jsi vložil stejnou SD kartu se systémem, nebo má svou.
I s nějakým jiným systémem bys měl aspoň vidět start RPI s "oranžovou duhovou" obrazovkou.
Třeba si opravdu ta dvě zařízení společně nerozumí s tím HDMI kabelem, co máš. Zkus pořídit HDMI 1.4 (někdy označený jako High Speed, podpora ethernet a 3D) a nejlépe 50cm.
Další nápady už nemám...... Snad jen zkusit LibreElec 8.2.x

mám 2 ks RPI s prakticky stejnou instalací - zkoušel jsem vše - měnit karty, měnit kabely. U jedné TV jede vše vpořádku - u té druhé prostě RPI nejsou vidět - TV hlásí "bez signálu"
není vidět ani start systému.
Zkusím tedy kabel, který popisuješ, popřípadě jinou instalaci - tedy LibreElec.

Tak ani HDMI High Speed kabel nepomohl...
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
#18
Hmmmmm..... Pak už jen použít méně kvalitní analogový výstup 3,5mm z RPi3. Kabel má na jednom konci Jack a na druhém 3 Cinche: Video(žlutý)/Audio-L(bílý)/R(červený). Zvuk může šumět; podle kvality RPi.
Popsaný je tady: http://www.xbmc-kodi.cz/prispevek-raspbe...video-jack
Společná zem (stínění) je od špičky na 3. a od krytu na 2. kontaktu, to je od jiných kablíků rozdíl.
V OpenElec nebo LE to musíš nastavit.
Kodi 19/18.x -LibreELEC 9.1.x-BerryBoot -RPi4/3/0/w -LinuxMint/W10/Android 11/10. Router 1Gbit, 2.4+5GHz
 
Citovat
#19
V případě že vynucené posílání dat přes HDMI nezabere, doporučuje se tento zápis :

Kód:
hdmi_force_hotplug=1, hdmi_ignore_edid=0xa5000080, config_hdmi_boost=4, hdmi_group=2, hdmi_mode=4, disable_overscan=0, overscan_left=24, overscan_right=24, overscan_top=24 et overscan_bottom=24


Zdroj: Raspberry Pi HDMI display not working, how to solve it?
RPi 4B - LibreELEC
RPi Zero W - LibreELEC
 
Citovat
#20
(16.4.2018, 16:07)Petrvald Napsal(a): V případě že vynucené posílání dat přes HDMI nezabere, doporučuje se tento zápis :

Kód:
hdmi_force_hotplug=1, hdmi_ignore_edid=0xa5000080, config_hdmi_boost=4, hdmi_group=2, hdmi_mode=4, disable_overscan=0, overscan_left=24, overscan_right=24, overscan_top=24 et overscan_bottom=24


Zdroj: Raspberry Pi HDMI display not working, how to solve it?

Zkusím - díky...
2x RPi3 - OpenELEC  6.03 → Kodi 16.1 \ 1x PC - Windows 10  → Kodi 16.1 \ 1x Acer Iconia - Kitekat 4.4.4  → Kodi 16.1
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)