• Vítejte na XBMC-Kodi.cz
  • Česko-slovenská komunita fanoušků XBMC/Kodi
Zdravím hosta! Přihlášení Registrace




Hodnocení tématu:
  • 0 Hlas(ů) - 0 Průměr
  • 1
  • 2
  • 3
  • 4
  • 5
nepřehraji avi-mpeg4
#1
Zdraví, jsme nový uživatel HTPC postavené na AMD Athlon 200GE. Pc běží na win10 a mám nainstalovanou poslední versi kodi. Zjistil jsem že mi kodi nepřehrává AVI/mpeg4. Pokud pustím jakýkoliv soubor v tomto formátu hraje jenom zvuk. Zkoušel jsem i AVI/h-264 a ten běží naprosto v pořádku. Prosím poraďte co s tím. Doinstalovat kodek ? Změnit nastavení ? Pokud video soubor pustím přímo ve windows hraje naprosto bezproblémů. Moc děkuji za radu.
 
Citovat
#2
mam tu samou zkušenost HTPC na ryzenu 2400G,ale na pc s gpu invidia problem není,stejny os (zatim se sah po ubuntu a běha to fajn)
 
Citovat
#3
coodlik: Takže řešení aby to fungovalo na AMD procesorech a win10 jsi nenašel? Pro badatele připojuji log. [Only registered and activated users can see links Click here to register] film který jsem se pokoušel přehrát se jmenuje Malá čarodějnice.avi
 
Citovat
#4
@videoFish Pravděpodobně problémy s akcelerací. Nejsem si jistý, ale za vyzkoušení nic nedáš. Pro začátek se podívej, zda náhodou máš povolenou Správu barev, pokud ano, tak ji zkus zakázat. Budu to popisovat pro skin Estuary, tak si raději přepni na něj:
  1. Při přehrávání videa zadej na klávesnici <Enter>
  2. V dolní části obrazovky, se objeví řada icon, zvol 1. zprava ("ozubené kolo" == Nastavení)
  3. V zobrazeném okně Nastavení zvol Správa barev
  4. V dalším zobrazeném okně Správa barev by 1. položka měla být Správa barev, je-li zapnutá, tak ji vypni
  5. Ukonči Kodi a znova ho spusť
ASUS VivoMini + LE 9.0.2 (Kodi 18.2) + Tvheadend 4.2 * ASUS VivoMini + LE 9.0.2 (Kodi 18.2) * 3x PC + W10 (Kodi 18.2)
 
Citovat
#5
A když se změní header souboru na třeba H264, tak se stane co ?
Lze změnit třeba pomocí FoutCCChanger, ale dělal jsem to naposledy v minulém století.

Osobně bych si s tím nelámal hlavu a vše přehrkal dávkově do MKV v MKVToolnix, bez rekomprese je to otázka minut.
Evolveo H8 - LibreElec, Kodi 17.6, Dune BD Prime 3.0, Yamaha 7.1, repro Magnat, Panasonic plasma 165 cm, video Akai, Sony MiniDisc, VU+ Solo 4K a mnoho dalšího bordelu.
 
Citovat
#6
(10.7.2019, 11:54)Client Napsal(a): @videoFish Pravděpodobně problémy s akcelerací. Nejsem si jistý, ale za vyzkoušení nic nedáš. Pro začátek se podívej, zda náhodou máš povolenou Správu barev, pokud ano, tak ji zkus zakázat. Budu to popisovat pro skin Estuary, tak si raději přepni na něj:
  1. Při přehrávání videa zadej na klávesnici <Enter>
  2. V dolní části obrazovky, se objeví řada icon, zvol 1. zprava ("ozubené kolo" == Nastavení)
  3. V zobrazeném okně Nastavení zvol Správa barev
  4. V dalším zobrazeném okně Správa barev by 1. položka měla být Správa barev, je-li zapnutá, tak ji vypni
  5. Ukonči Kodi a znova ho spusť

Tak bohužel správa barev byla vypnutá. Zkoušel jsem ještě přepínat další volby a bez výsledku. Stále jen zvuk a obraz nikde.

(10.7.2019, 15:14)Foolproof Napsal(a): A když se změní header souboru na třeba H264, tak se stane co ?
Lze změnit třeba pomocí FoutCCChanger, ale dělal jsem to naposledy v minulém století.

Osobně bych si s tím nelámal hlavu a vše přehrkal dávkově do MKV v MKVToolnix, bez rekomprese je to otázka minut.

Tak změnit hlavičku jsem ještě nezkoušel ale přepočet také bez pozitivního výsledku. Proste kodek Mpeg4 to nechce z nějakého důvodu přehrát ani v avi a ani v mkv. Jinak ten MKVToolnix je fajn. Divný je že že ve widlích to i na tom defaultním přehrávači hraje neprosto bez problémů.
 
Citovat
#7
@videoFish Zkoušel jsi varianty nastavení Kodi přehrávače v Nastavení > Přehrávač > Video? Měl bys mít nastaveno Metoda vykreslení na Automatické rozpoznávání. Případně zkus při dalším pokusu vypnout HW akceleraci úplně, zda to pak půjde přehrát. Vím, není to řešení, pro jiné soubory ji budeš potřebovat, ale mnohé to může napovědět.

P.S. Šetři s citacemi, v takovýchto případech jsou zbytečné. Viz [Only registered and activated users can see links Click here to register], bod 6.
ASUS VivoMini + LE 9.0.2 (Kodi 18.2) + Tvheadend 4.2 * ASUS VivoMini + LE 9.0.2 (Kodi 18.2) * 3x PC + W10 (Kodi 18.2)
 
Citovat
#8
Předpokládám ve Win 10 instalaci poslední verze ze Store. Já jsem raději instaloval 17.6 verzi EXE 32bit. (Dříve AMD, současně Intel.)
Mohl bys vyzkoušet (je tam 32 i 64 bit) [Only registered and activated users can see links Click here to register]
Kodi 17.6 -LibreELEC 8.2.5 -BerryBoot -RPi3/2/0/w. Kodi 17.6 -LinuxMint/W7/10. Kodi 18.3 -Android 9 -Tablet 10. Router 1Gbit, 2.4+5GHz
 
Citovat
#9
Já jsem Kodi instaloval jako normální aplikaci do Windows ( stáhnul z webu a instaloval) ne z win store.
 
Citovat
#10
Ustřihni kousek toho MPEP4 v AVI a někam to pověs, něco zkusím.
Evolveo H8 - LibreElec, Kodi 17.6, Dune BD Prime 3.0, Yamaha 7.1, repro Magnat, Panasonic plasma 165 cm, video Akai, Sony MiniDisc, VU+ Solo 4K a mnoho dalšího bordelu.
 
Citovat
#11
Tak už to maká :) Musel jsem přepnout v "System-nastavení-přehrávač metoda vykreslení" na Softwarově. Hadware akceleraci jsem ponechal na DXVA2 (to je asi teď zbytečné). Zatím nevím jaký to bude mít vliv na rozkódování ostatních kodeků ale co jsem zkoušel tak mkv či h264 tak ty hrály také. Ještě jsem zapnul "Upravit obnovovací frekvenci obrazovky" na on a "Synchronizovat přehrávání k zobrazení" také na on. Přišlo mi že ty videa při přehrávání jsou plynulejší. Vytížení procesoru se pohybuje od 6 do 12 procent na FullHD mkv/h-264. (AMD Athlon 200GE, ASROCK Fatal1ty B450 Gaming-ITX/ac a 8 GB DDR4).

Všem vám moc děkuji.
 
Citovat
#12
@videoFish Tak to jsme rád, že to pomohlo. To vždycky potěší.

Jinak, ta zlepšená plynulost přehrávání po "Upravit obnovovací frekvenci obrazovky" na on a "Synchronizovat přehrávání k zobrazení" na on, to zní logicky. Jen bacha, u toho druhého to má případně vliv na průchod zvuku, ten při on nebude fungovat.

Jen by mě zajímalo, jak jsi měl před tím nastavenou metodu vykreslení - Automatické rozpoznávání nebo DXVA2? Pokud DXVA2, zkus ještě dát Automatické rozpoznávání, jestli to bude fungovat i s tím. Docela by to zajímalo.
ASUS VivoMini + LE 9.0.2 (Kodi 18.2) + Tvheadend 4.2 * ASUS VivoMini + LE 9.0.2 (Kodi 18.2) * 3x PC + W10 (Kodi 18.2)
 
Citovat
#13
Automatické rozpoznání nefunguje. To tam bylo defaultně. Osobně si myslím že celý problém z hw akcelerací je způsobený tím že garfika radeon co tam je, je součástí cpu a kodi neví moc co stím. Je ale zvláštní že se to týkalo jen mpeg4 kodeku zbytek makal jak má. Pokud jsem kodi nainstaloval na můj pracovní I7 s Nvidii GTX 660 Ti tak vše makalo na 1 i s HW akcelerací.
 
Citovat
#14
@videoFish To zda je GPU integrovaná nebo dedikovaná GPU nehraje roli. Rozhodující je, zda řetězec systém - driver - GPU dokáže Kodi nabídnout to, co pro dané nastavení potřebuje.

Hele, pokud ti to SW renderování bude CPU zvládat, tak to prostě neřeš. Jinak vlastní dekódování ti na GPU jede, a to je podstatnější.

BTW A nastavit Pixel Shader jsi nezkoušel? A co případný update driveru?
ASUS VivoMini + LE 9.0.2 (Kodi 18.2) + Tvheadend 4.2 * ASUS VivoMini + LE 9.0.2 (Kodi 18.2) * 3x PC + W10 (Kodi 18.2)
 
Citovat
#15
PIxel shader jsem taky zkoušel a opět bez obrazu jen zvuk. No po ovladačích se ještě můžu kouknout ručně. Nechal jsem to na automatické aktualizaci. Je pravda že firma ATI co mne pamět sahá do historie ( a že je to jíž opravdu hodně hluboko :)) ) měla vždy s ovladači nějaké trable proto jsme je ve 3D nikdy nepoužívali a to i přes jejich kdysi vynikající řadu karet FireGL.
 
Citovat
#16
@videoFish No vidíš, a já mám doma stále ještě funkční prastarou mini-itx desku s ION 330, na které jsem léta (> 10) pod Windows provozoval dlouho MediaPortal, pak Kodi a nakonec tam nainstaloval i LibreELEC a vždy mi všechno jelo na první zapnutí a bez jakýchkoliv problémů.
ASUS VivoMini + LE 9.0.2 (Kodi 18.2) + Tvheadend 4.2 * ASUS VivoMini + LE 9.0.2 (Kodi 18.2) * 3x PC + W10 (Kodi 18.2)
 
Citovat
#17
No já jsem mysle dobu tak před 25 lety :))))) . Na linuxu to běhá nějak lépe to jsem na netu vyčetl. Ale nechám tam windows .
 
Citovat
  


Přejít na fórum:


Prochází: 1 host(ů)